CVE-2025-23387 Rancher's SAML-based login via CLI can be denied by unauthenticated users
Unauthenticated attackers can list and delete CLI authentication tokens, causing denial of service for legitimate users.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-23387?
CVE-2025-23387 is a medium-severity vulnerability in SUSE rancher, published on 11 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A Exposure of Sensitive Information to an Unauthorized Actor vulnerability in SUSE rancher allowed unauthenticated users to list all CLI authentication tokens and delete them before the CLI is able to get the token value.This issue affects rancher: from 2.8.0 before 2.8.13, from 2.9.0 before 2.9.7, from 2.10.0 before 2.10.3.
Weakness: CWE-200
Which versions are affected by CVE-2025-23387?
7 open source packages ship an affected version, including github.com/rancher/rancher.
| Package | Affected | Fixed in |
|---|---|---|
github.com/rancher/rancher Go | All versions | None |
github.com/rancher/rancher Go | From 2.10.0 | 2.10.3 |
github.com/rancher/rancher Go | From 2.10.0 | 2.10.3 |
github.com/rancher/rancher Go | From 2.8.0 | 2.8.13 |
github.com/rancher/rancher Go | From 2.8.0 | 2.8.13 |
github.com/rancher/rancher Go | From 2.9.0 | 2.9.7 |
1 more packages
github.com/rancher/rancher Go | From 2.9.0 | 2.9.7 |
How do I fix CVE-2025-23387?
Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.10.3, 2.8.13 or 2.9.7.
Is CVE-2025-23387 being exploited?
There is no known exploitation of CVE-2025-23387 in the wild and no public exploit code.
Sources
Also known as GHSA-5qmp-9x47-92q8, GO-2025-3489.