# CVE-2025-23387: Rancher's SAML-based login via CLI can be denied by unauthenticated users

> Unauthenticated attackers can list and delete CLI authentication tokens, causing denial of service for legitimate users.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2025
- **Updated:** 11 Apr 2025
- **Also known as:** GHSA-5qmp-9x47-92q8, GO-2025-3489

## What is CVE-2025-23387?

CVE-2025-23387 is a medium-severity vulnerability in SUSE rancher, published on 11 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A Exposure of Sensitive Information to an Unauthorized Actor vulnerability in SUSE rancher allowed unauthenticated users to list all CLI authentication tokens and delete them before the CLI is able to get the token value.This issue affects rancher: from 2.8.0 before 2.8.13, from 2.9.0 before 2.9.7, from 2.10.0 before 2.10.3.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-23387?

7 open source packages ship an affected version, including github.com/rancher/rancher.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/rancher` | Go | All versions | None |
| `github.com/rancher/rancher` | Go | From 2.10.0 | 2.10.3 |
| `github.com/rancher/rancher` | Go | From 2.10.0 | 2.10.3 |
| `github.com/rancher/rancher` | Go | From 2.8.0 | 2.8.13 |
| `github.com/rancher/rancher` | Go | From 2.8.0 | 2.8.13 |
| `github.com/rancher/rancher` | Go | From 2.9.0 | 2.9.7 |
| `github.com/rancher/rancher` | Go | From 2.9.0 | 2.9.7 |

## How do I fix CVE-2025-23387?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.10.3, 2.8.13 or 2.9.7.

## Is CVE-2025-23387 being exploited?

There is no known exploitation of CVE-2025-23387 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23387 and fix it if it is affected.

What it is: CVE-2025-23387 is a medium-severity vulnerability in SUSE rancher, published on 11 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-23387 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/rancher (Go): affected all versions; no fix listed
- github.com/rancher/rancher (Go): affected from 2.10.0; fixed in 2.10.3
- github.com/rancher/rancher (Go): affected from 2.10.0; fixed in 2.10.3
- github.com/rancher/rancher (Go): affected from 2.8.0; fixed in 2.8.13
- github.com/rancher/rancher (Go): affected from 2.8.0; fixed in 2.8.13
- github.com/rancher/rancher (Go): affected from 2.9.0; fixed in 2.9.7
- github.com/rancher/rancher (Go): affected from 2.9.0; fixed in 2.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23387/ (Markdown: https://insights.sbomify.com/CVE-2025-23387/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23387
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23387
- OSV: https://osv.dev/vulnerability/CVE-2025-23387

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23387/
Summaries are generated and may contain mistakes; the official description above is the record.
