CVE-2025-23388 Unauthenticated stack overflow in /v3-public/authproviders API
Unauthenticated attackers can cause a stack overflow and denial of service in the Rancher authentication provider API.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-23388?
CVE-2025-23388 is a high-severity denial of service vulnerability in SUSE rancher, published on 11 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
A Stack-based Buffer Overflow vulnerability in SUSE rancher allows for denial of service.This issue affects rancher: from 2.8.0 before 2.8.13, from 2.9.0 before 2.9.7, from 2.10.0 before 2.10.3.
Weakness: CWE-121
Which versions are affected by CVE-2025-23388?
7 open source packages ship an affected version, including github.com/rancher/rancher.
| Package | Affected | Fixed in |
|---|---|---|
github.com/rancher/rancher Go | All versions | None |
github.com/rancher/rancher Go | From 2.10.0 | 2.10.3 |
github.com/rancher/rancher Go | From 2.10.0 | 2.10.3 |
github.com/rancher/rancher Go | From 2.8.0 | 2.8.13 |
github.com/rancher/rancher Go | From 2.8.0 | 2.8.13 |
github.com/rancher/rancher Go | From 2.9.0 | 2.9.7 |
1 more packages
github.com/rancher/rancher Go | From 2.9.0 | 2.9.7 |
How do I fix CVE-2025-23388?
Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.10.3, 2.8.13 or 2.9.7.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2025-23388 being exploited?
There is no known exploitation of CVE-2025-23388 in the wild and no public exploit code.
Sources
Also known as GHSA-xr9q-h9c7-xw8q, GO-2025-3491.