{"answers":{"affected":"7 open source packages ship an affected version, including github.com/rancher/rancher.","exploited":"There is no known exploitation of CVE-2025-23388 in the wild and no public exploit code.","fix":"Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.10.3, 2.8.13 or 2.9.7.","what":"CVE-2025-23388 is a high-severity denial of service vulnerability in SUSE rancher, published on 11 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-23388 and fix it if it is affected.\n\nWhat it is: CVE-2025-23388 is a high-severity denial of service vulnerability in SUSE rancher, published on 11 Apr 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-23388 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/rancher/rancher (Go): affected all versions; no fix listed\n- github.com/rancher/rancher (Go): affected from 2.10.0; fixed in 2.10.3\n- github.com/rancher/rancher (Go): affected from 2.10.0; fixed in 2.10.3\n- github.com/rancher/rancher (Go): affected from 2.8.0; fixed in 2.8.13\n- github.com/rancher/rancher (Go): affected from 2.8.0; fixed in 2.8.13\n- github.com/rancher/rancher (Go): affected from 2.9.0; fixed in 2.9.7\n- github.com/rancher/rancher (Go): affected from 2.9.0; fixed in 2.9.7\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-23388/ (Markdown: https://insights.sbomify.com/CVE-2025-23388/index.md)","id":"CVE-2025-23388","markdown":"https://insights.sbomify.com/CVE-2025-23388/index.md","name":"CVE-2025-23388","record":{"aliases":["GHSA-xr9q-h9c7-xw8q","GO-2025-3491"],"analysis":{"component_type":"container_or_infrastructure","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rancher container platform","requires_auth":"none","summary":"Unauthenticated attackers can cause a stack overflow and denial of service in the Rancher authentication provider API.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"suse","cpe":[],"cvss":{"score":8.2,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-121","name":"Stack-based Buffer Overflow"}],"description":"A Stack-based Buffer Overflow vulnerability in SUSE rancher allows for denial of service.This issue affects rancher: from 2.8.0 before 2.8.13, from 2.9.0 before 2.9.7, from 2.10.0 before 2.10.3.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Unauthenticated stack overflow in /v3-public/authproviders API","id":"CVE-2025-23388","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"denial_of_service","year":"2025"},"n_packages":7,"n_references":2,"next":{"headline":"Rancher does not Properly Validate Account Bindings in SAML Authentication Enables User Impersonation on First Login","id":"CVE-2025-23389"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":"pkg:golang/github.com/rancher/rancher","source":"GO-2025-3491"},{"ecosystem":"Go","fixed":["2.10.3"],"introduced":["2.10.0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":null,"source":"GHSA-xr9q-h9c7-xw8q"},{"ecosystem":"Go","fixed":["2.10.3"],"introduced":["2.10.0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":"pkg:golang/github.com/rancher/rancher","source":"GHSA-xr9q-h9c7-xw8q"},{"ecosystem":"Go","fixed":["2.8.13"],"introduced":["2.8.0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":null,"source":"GHSA-xr9q-h9c7-xw8q"},{"ecosystem":"Go","fixed":["2.8.13"],"introduced":["2.8.0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":"pkg:golang/github.com/rancher/rancher","source":"GHSA-xr9q-h9c7-xw8q"},{"ecosystem":"Go","fixed":["2.9.7"],"introduced":["2.9.0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":null,"source":"GHSA-xr9q-h9c7-xw8q"},{"ecosystem":"Go","fixed":["2.9.7"],"introduced":["2.9.0"],"last_affected":[],"package":"github.com/rancher/rancher","purl":"pkg:golang/github.com/rancher/rancher","source":"GHSA-xr9q-h9c7-xw8q"}],"prev":{"headline":"Rancher's SAML-based login via CLI can be denied by unauthenticated users","id":"CVE-2025-23387"},"products":["rancher"],"published":"2025-04-11","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-04-15","vendors":["SUSE"]},"summary":"Unauthenticated attackers can cause a stack overflow and denial of service in the Rancher authentication provider API.","url":"https://insights.sbomify.com/CVE-2025-23388/"}