CVE-2025-23389 Rancher does not Properly Validate Account Bindings in SAML Authentication Enables User Impersonation on First Login
A local user can impersonate other identities via SAML authentication on first login, leading to privilege escalation and account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-23389?
CVE-2025-23389 is a high-severity authentication bypass vulnerability in SUSE rancher, published on 11 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
A Improper Access Control vulnerability in SUSE rancher allows a local user to impersonate other identities through SAML Authentication on first login. This issue affects rancher: from 2.8.0 before 2.8.13, from 2.9.0 before 2.9.7, from 2.10.0 before 2.10.3.
Weakness: CWE-284
Which versions are affected by CVE-2025-23389?
7 open source packages ship an affected version, including github.com/rancher/rancher.
| Package | Affected | Fixed in |
|---|---|---|
github.com/rancher/rancher Go | All versions | None |
github.com/rancher/rancher Go | From 2.10.0 | 2.10.3 |
github.com/rancher/rancher Go | From 2.10.0 | 2.10.3 |
github.com/rancher/rancher Go | From 2.8.0 | 2.8.13 |
github.com/rancher/rancher Go | From 2.8.0 | 2.8.13 |
github.com/rancher/rancher Go | From 2.9.0 | 2.9.7 |
1 more packages
github.com/rancher/rancher Go | From 2.9.0 | 2.9.7 |
How do I fix CVE-2025-23389?
Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.10.3, 2.8.13 or 2.9.7.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-23389 being exploited?
There is no known exploitation of CVE-2025-23389 in the wild and no public exploit code.
Sources
Also known as GHSA-mq23-vvg7-xfm4, GO-2025-3490.