# CVE-2025-23389: Rancher does not Properly Validate Account Bindings in SAML Authentication Enables User Impersonation on First Login

> A local user can impersonate other identities via SAML authentication on first login, leading to privilege escalation and account takeover.

- **Severity:** High 8.4 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-mq23-vvg7-xfm4, GO-2025-3490

## What is CVE-2025-23389?

CVE-2025-23389 is a high-severity authentication bypass vulnerability in SUSE rancher, published on 11 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A Improper Access Control vulnerability in SUSE rancher allows a local user to impersonate other identities through SAML Authentication on first login.
This issue affects rancher: from 2.8.0 before 2.8.13, from 2.9.0 before 2.9.7, from 2.10.0 before 2.10.3.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2025-23389?

7 open source packages ship an affected version, including github.com/rancher/rancher.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/rancher` | Go | All versions | None |
| `github.com/rancher/rancher` | Go | From 2.10.0 | 2.10.3 |
| `github.com/rancher/rancher` | Go | From 2.10.0 | 2.10.3 |
| `github.com/rancher/rancher` | Go | From 2.8.0 | 2.8.13 |
| `github.com/rancher/rancher` | Go | From 2.8.0 | 2.8.13 |
| `github.com/rancher/rancher` | Go | From 2.9.0 | 2.9.7 |
| `github.com/rancher/rancher` | Go | From 2.9.0 | 2.9.7 |

## How do I fix CVE-2025-23389?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.10.3, 2.8.13 or 2.9.7.

## Is CVE-2025-23389 being exploited?

There is no known exploitation of CVE-2025-23389 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23389 and fix it if it is affected.

What it is: CVE-2025-23389 is a high-severity authentication bypass vulnerability in SUSE rancher, published on 11 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-23389 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/rancher (Go): affected all versions; no fix listed
- github.com/rancher/rancher (Go): affected from 2.10.0; fixed in 2.10.3
- github.com/rancher/rancher (Go): affected from 2.10.0; fixed in 2.10.3
- github.com/rancher/rancher (Go): affected from 2.8.0; fixed in 2.8.13
- github.com/rancher/rancher (Go): affected from 2.8.0; fixed in 2.8.13
- github.com/rancher/rancher (Go): affected from 2.9.0; fixed in 2.9.7
- github.com/rancher/rancher (Go): affected from 2.9.0; fixed in 2.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23389/ (Markdown: https://insights.sbomify.com/CVE-2025-23389/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23389
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23389
- OSV: https://osv.dev/vulnerability/CVE-2025-23389

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23389/
Summaries are generated and may contain mistakes; the official description above is the record.
