CVE-2025-23391 Rancher: Restricted Administrator can change Administrator's passwords
A Restricted Administrator can change Administrator passwords, leading to account takeover and privilege escalation in Rancher.
- Exploited in the wild
- Not known
- Login needed
- An administrator
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-23391?
CVE-2025-23391 is a critical vulnerability in SUSE rancher, published on 11 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Official description
A Incorrect Privilege Assignment vulnerability in SUSE rancher allows a Restricted Administrator to change the password of Administrators and take over their accounts. This issue affects rancher: from 2.8.0 before 2.8.14, from 2.9.0 before 2.9.8, from 2.10.0 before 2.10.4.
Weakness: CWE-266
Which versions are affected by CVE-2025-23391?
7 open source packages ship an affected version, including github.com/rancher/rancher.
| Package | Affected | Fixed in |
|---|---|---|
github.com/rancher/rancher Go | All versions | None |
github.com/rancher/rancher Go | From 2.10.0 | 2.10.4 |
github.com/rancher/rancher Go | From 2.10.0 | 2.10.4 |
github.com/rancher/rancher Go | From 2.8.0 | 2.8.14 |
github.com/rancher/rancher Go | From 2.8.0 | 2.8.14 |
github.com/rancher/rancher Go | From 2.9.0 | 2.9.8 |
1 more packages
github.com/rancher/rancher Go | From 2.9.0 | 2.9.8 |
How do I fix CVE-2025-23391?
Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.10.4, 2.8.14 or 2.9.8.
Is CVE-2025-23391 being exploited?
There is no known exploitation of CVE-2025-23391 in the wild and no public exploit code.
Sources
Also known as GHSA-8p83-cpfg-fj3g, GO-2025-3586.