# CVE-2025-23391: Rancher: Restricted Administrator can change Administrator's passwords

> A Restricted Administrator can change Administrator passwords, leading to account takeover and privilege escalation in Rancher.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Apr 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-8p83-cpfg-fj3g, GO-2025-3586

## What is CVE-2025-23391?

CVE-2025-23391 is a critical vulnerability in SUSE rancher, published on 11 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A Incorrect Privilege Assignment vulnerability in SUSE rancher allows a Restricted Administrator to change the password of Administrators and take over their accounts.
This issue affects rancher: from 2.8.0 before 2.8.14, from 2.9.0 before 2.9.8, from 2.10.0 before 2.10.4.

Weakness: CWE-266 (Incorrect Privilege Assignment)

## Which versions are affected by CVE-2025-23391?

7 open source packages ship an affected version, including github.com/rancher/rancher.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/rancher/rancher` | Go | All versions | None |
| `github.com/rancher/rancher` | Go | From 2.10.0 | 2.10.4 |
| `github.com/rancher/rancher` | Go | From 2.10.0 | 2.10.4 |
| `github.com/rancher/rancher` | Go | From 2.8.0 | 2.8.14 |
| `github.com/rancher/rancher` | Go | From 2.8.0 | 2.8.14 |
| `github.com/rancher/rancher` | Go | From 2.9.0 | 2.9.8 |
| `github.com/rancher/rancher` | Go | From 2.9.0 | 2.9.8 |

## How do I fix CVE-2025-23391?

Upgrade github.com/rancher/rancher to a fixed version for your release line: 2.10.4, 2.8.14 or 2.9.8.

## Is CVE-2025-23391 being exploited?

There is no known exploitation of CVE-2025-23391 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23391 and fix it if it is affected.

What it is: CVE-2025-23391 is a critical vulnerability in SUSE rancher, published on 11 Apr 2025. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-23391 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/rancher/rancher (Go): affected all versions; no fix listed
- github.com/rancher/rancher (Go): affected from 2.10.0; fixed in 2.10.4
- github.com/rancher/rancher (Go): affected from 2.10.0; fixed in 2.10.4
- github.com/rancher/rancher (Go): affected from 2.8.0; fixed in 2.8.14
- github.com/rancher/rancher (Go): affected from 2.8.0; fixed in 2.8.14
- github.com/rancher/rancher (Go): affected from 2.9.0; fixed in 2.9.8
- github.com/rancher/rancher (Go): affected from 2.9.0; fixed in 2.9.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23391/ (Markdown: https://insights.sbomify.com/CVE-2025-23391/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23391
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23391
- OSV: https://osv.dev/vulnerability/CVE-2025-23391

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23391/
Summaries are generated and may contain mistakes; the official description above is the record.
