CVE-2025-23408 Apache Fineract: weak password policy
Weak password requirements in Apache Fineract allow attackers to guess credentials and take over user accounts.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-23408?
CVE-2025-23408 is a high-severity vulnerability in Apache Fineract, published on 12 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Weak Password Requirements vulnerability in Apache Fineract.
This issue affects Apache Fineract: through 1.10.1. The issue is fixed in version 1.11.0.
Users are encouraged to upgrade to version 1.13.0, the latest release.
Weakness: CWE-521
Which versions are affected by CVE-2025-23408?
It affects 1 product.
Products include Apache Fineract.
How do I fix CVE-2025-23408?
No fix has been published for CVE-2025-23408 yet. Limit exposure of the affected software until one is available.
Is CVE-2025-23408 being exploited?
There is no known exploitation of CVE-2025-23408 in the wild and no public exploit code.
Other vulnerabilities in Apache Fineract
Sources
Also known as GHSA-6jvx-rr4c-j9j5.