# CVE-2025-23408: Apache Fineract: weak password policy

> Weak password requirements in Apache Fineract allow attackers to guess credentials and take over user accounts.

- **Severity:** High 8.5 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 12 Dec 2025
- **Updated:** 18 Dec 2025
- **Also known as:** GHSA-6jvx-rr4c-j9j5

## What is CVE-2025-23408?

CVE-2025-23408 is a high-severity vulnerability in Apache Fineract, published on 12 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Weak Password Requirements vulnerability in Apache Fineract.

This issue affects Apache Fineract: through 1.10.1. The issue is fixed in version 1.11.0.

Users are encouraged to upgrade to version 1.13.0, the latest release.

Weakness: CWE-521 (Weak Password Requirements)

## Which versions are affected by CVE-2025-23408?

It affects 1 product.


Products: Apache Fineract.

## How do I fix CVE-2025-23408?

No fix has been published for CVE-2025-23408 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-23408 being exploited?

There is no known exploitation of CVE-2025-23408 in the wild and no public exploit code.

## Other vulnerabilities in Apache Fineract

- [CVE-2024-23538](https://insights.sbomify.com/CVE-2024-23538/): SQL injection in Apache Fineract (critical 9.9)
- [CVE-2018-11800](https://insights.sbomify.com/CVE-2018-11800/): SQL injection in Apache Fineract (critical 9.8)
- [CVE-2018-11801](https://insights.sbomify.com/CVE-2018-11801/): SQL injection in Apache Fineract (critical 9.8)
- [CVE-2018-1290](https://insights.sbomify.com/CVE-2018-1290/): SQL injection in Apache Fineract (critical 9.8)
- [CVE-2024-32838](https://insights.sbomify.com/CVE-2024-32838/): Apache Fineract: SQL injection vulnerabilities in offices API endpoint (critical 9.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-23408 and fix it if it is affected.

What it is: CVE-2025-23408 is a high-severity vulnerability in Apache Fineract, published on 12 Dec 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-23408 in the wild and no public exploit code.

Affected product: Apache Fineract. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-23408/ (Markdown: https://insights.sbomify.com/CVE-2025-23408/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-23408
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-23408
- OSV: https://osv.dev/vulnerability/CVE-2025-23408

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-23408/
Summaries are generated and may contain mistakes; the official description above is the record.
