# CVE-2025-24013: CodeIgniter validation of header name and value

> Attackers can send malformed headers to disrupt application functionality or trigger DoS via WAF blocking, affecting CodeIgniter users.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jan 2025
- **Updated:** 21 Jan 2025
- **Also known as:** GHSA-x5mq-jjr3-vmx6

## What is CVE-2025-24013?

CVE-2025-24013 is a medium-severity denial of service vulnerability in CodeIgniter4, published on 20 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

CodeIgniter is a PHP full-stack web framework. Prior to 4.5.8, CodeIgniter lacked proper header validation for its name and value. The potential attacker can construct deliberately malformed headers with Header class. This could disrupt application functionality, potentially causing errors or generating invalid HTTP requests. In some cases, these malformed requests might lead to a DoS scenario if a remote service’s web application firewall interprets them as malicious and blocks further communication with the application. This vulnerability is fixed in 4.5.8.

Weakness: CWE-436 (Interpretation Conflict)

## Which versions are affected by CVE-2025-24013?

2 open source packages ship an affected version, including codeigniter4/framework. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `codeigniter4/framework` | Packagist | All versions | 4.5.8 |
| `codeigniter4/framework` | Packagist | All versions | 4.5.8 |

Products: Codeigniter Codeigniter.

## How do I fix CVE-2025-24013?

Upgrade codeigniter4/framework to 4.5.8 or later.

## Is CVE-2025-24013 being exploited?

There is no known exploitation of CVE-2025-24013 in the wild and no public exploit code.

## Other vulnerabilities in CodeIgniter4

- [CVE-2025-54418](https://insights.sbomify.com/CVE-2025-54418/): CodeIgniter4's ImageMagick Handler has Command Injection Vulnerability (critical 9.8)
- [CVE-2023-32692](https://insights.sbomify.com/CVE-2023-32692/): Remote Code Execution Vulnerability in Validation Placeholders (critical 9.8)
- [CVE-2022-40824](https://insights.sbomify.com/CVE-2022-40824/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40825](https://insights.sbomify.com/CVE-2022-40825/): SQL injection in n/a (critical 9.8)
- [CVE-2022-40826](https://insights.sbomify.com/CVE-2022-40826/): SQL injection in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24013 and fix it if it is affected.

What it is: CVE-2025-24013 is a medium-severity denial of service vulnerability in CodeIgniter4, published on 20 Jan 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24013 in the wild and no public exploit code.

Affected packages and fixed versions:
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.5.8
- codeigniter4/framework (Packagist): affected all versions; fixed in 4.5.8

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24013/ (Markdown: https://insights.sbomify.com/CVE-2025-24013/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24013
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24013
- OSV: https://osv.dev/vulnerability/CVE-2025-24013

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24013/
Summaries are generated and may contain mistakes; the official description above is the record.
