{"answers":{"affected":"4 open source packages ship an affected version, including deno and deno_node. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24015 exists.","fix":"Upgrade deno to 2.1.7 or later.","what":"CVE-2025-24015 is a high-severity vulnerability in denoland deno, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-24015 and fix it if it is affected.\n\nWhat it is: CVE-2025-24015 is a high-severity vulnerability in denoland deno, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24015 exists.\n\nAffected packages and fixed versions:\n- deno (crates.io): affected from 1.46.0; fixed in 2.1.7\n- deno (crates.io): affected from 1.46.0; fixed in 2.1.7\n- deno_node (crates.io): affected from 0.102.0; fixed in 0.125.0\n- deno_node (crates.io): affected from 0.102.0; fixed in 0.125.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24015/ (Markdown: https://insights.sbomify.com/CVE-2025-24015/index.md)","id":"CVE-2025-24015","markdown":"https://insights.sbomify.com/CVE-2025-24015/index.md","name":"CVE-2025-24015","record":{"aliases":["GHSA-2x3r-hwv5-p32x","JLSEC-2026-108"],"analysis":{"component_type":"developer_tool","fix_type":"patch","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"JavaScript runtime","requires_auth":"none","summary":"Deno fails to verify AES-GCM authentication tags, allowing undetected tampering of encrypted data and breaking integrity guarantees.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"deno","vendor":"deno"}],"cvss":{"score":7.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-347","name":"Improper Verification of Cryptographic Signature"}],"description":"Deno is a JavaScript, TypeScript, and WebAssembly runtime. Versions 1.46.0 through 2.1.6 have an issue that affects AES-256-GCM and AES-128-GCM in Deno in which the authentication tag is not being validated. This means tampered ciphertexts or incorrect keys might not be detected, which breaks the guarantees expected from AES-GCM. Older versions of Deno correctly threw errors in such cases, as does Node.js. Without authentication tag verification, AES-GCM degrades to essentially CTR mode, removing integrity protection. Authenticated data set with set_aad is also affected, as it is incorporated into the GCM hash (ghash) but this too is not validated, rendering AAD checks ineffective. Version 2.1.7 includes a patch that addresses this issue.","ecosystems":["crates.io"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Deno's AES GCM authentication tags are not verified","id":"CVE-2025-24015","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"weak_cryptography","year":"2025"},"n_packages":4,"n_references":4,"next":{"headline":"Wazuh Server Deserialization of Untrusted Data","id":"CVE-2025-24016"},"packages":[{"ecosystem":"crates.io","fixed":["2.1.7"],"introduced":["1.46.0"],"last_affected":[],"package":"deno","purl":null,"source":"GHSA-2x3r-hwv5-p32x"},{"ecosystem":"crates.io","fixed":["2.1.7"],"introduced":["1.46.0"],"last_affected":[],"package":"deno","purl":"pkg:cargo/deno","source":"GHSA-2x3r-hwv5-p32x"},{"ecosystem":"crates.io","fixed":["0.125.0"],"introduced":["0.102.0"],"last_affected":[],"package":"deno_node","purl":null,"source":"GHSA-2x3r-hwv5-p32x"},{"ecosystem":"crates.io","fixed":["0.125.0"],"introduced":["0.102.0"],"last_affected":[],"package":"deno_node","purl":"pkg:cargo/deno_node","source":"GHSA-2x3r-hwv5-p32x"}],"prev":{"headline":"segmentation fault in win_line() in Vim \u003c 9.1.1043","id":"CVE-2025-24014"},"products":["deno"],"published":"2025-06-03","related":[{"cvss_score":10,"headline":"Deno improperly handles resizable ArrayBuffer","id":"CVE-2023-28445","kev_date_added":null,"published":"2023-03-23"},{"cvss_score":10,"headline":"Sandbox bypass leading to arbitrary code execution in Deno","id":"CVE-2022-24783","kev_date_added":null,"published":"2022-03-25"},{"cvss_score":9.8,"headline":"Static imports inside dynamically imported modules do not adhere to permission checks","id":"CVE-2021-32619","kev_date_added":null,"published":"2021-05-28"},{"cvss_score":9.2,"headline":"Deno node:crypto doesn't finalize cipher","id":"CVE-2026-22863","kev_date_added":null,"published":"2026-01-15"},{"cvss_score":8.8,"headline":"Deno interactive permission prompt spoofing via improper ANSI stripping","id":"CVE-2024-27936","kev_date_added":null,"published":"2024-03-06"},{"cvss_score":8.8,"headline":"Deno is vulnerable to interactive `run` permission prompt spoofing via improper ANSI neutralization","id":"CVE-2023-28446","kev_date_added":null,"published":"2023-03-24"},{"cvss_score":8.6,"headline":"Deno missing \"--allow-net\" permission check for built-in Node modules","id":"CVE-2023-33966","kev_date_added":null,"published":"2023-05-31"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-06-04","vendors":["denoland"]},"summary":"Deno fails to verify AES-GCM authentication tags, allowing undetected tampering of encrypted data and breaking integrity guarantees.","url":"https://insights.sbomify.com/CVE-2025-24015/"}