# CVE-2025-24015: Deno's AES GCM authentication tags are not verified

> Deno fails to verify AES-GCM authentication tags, allowing undetected tampering of encrypted data and breaking integrity guarantees.

- **Severity:** High 7.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Jun 2025
- **Updated:** 4 Jun 2025
- **Also known as:** GHSA-2x3r-hwv5-p32x, JLSEC-2026-108

## What is CVE-2025-24015?

CVE-2025-24015 is a high-severity vulnerability in denoland deno, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Deno is a JavaScript, TypeScript, and WebAssembly runtime. Versions 1.46.0 through 2.1.6 have an issue that affects AES-256-GCM and AES-128-GCM in Deno in which the authentication tag is not being validated. This means tampered ciphertexts or incorrect keys might not be detected, which breaks the guarantees expected from AES-GCM. Older versions of Deno correctly threw errors in such cases, as does Node.js. Without authentication tag verification, AES-GCM degrades to essentially CTR mode, removing integrity protection. Authenticated data set with set_aad is also affected, as it is incorporated into the GCM hash (ghash) but this too is not validated, rendering AAD checks ineffective. Version 2.1.7 includes a patch that addresses this issue.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2025-24015?

4 open source packages ship an affected version, including deno and deno_node. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `deno` | crates.io | From 1.46.0 | 2.1.7 |
| `deno` | crates.io | From 1.46.0 | 2.1.7 |
| `deno_node` | crates.io | From 0.102.0 | 0.125.0 |
| `deno_node` | crates.io | From 0.102.0 | 0.125.0 |

Products: Deno Deno.

## How do I fix CVE-2025-24015?

Upgrade deno to 2.1.7 or later.

## Is CVE-2025-24015 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24015 exists.

## Other vulnerabilities in denoland deno

- [CVE-2023-28445](https://insights.sbomify.com/CVE-2023-28445/): Deno improperly handles resizable ArrayBuffer (critical 10.0)
- [CVE-2022-24783](https://insights.sbomify.com/CVE-2022-24783/): Sandbox bypass leading to arbitrary code execution in Deno (critical 10.0)
- [CVE-2021-32619](https://insights.sbomify.com/CVE-2021-32619/): Static imports inside dynamically imported modules do not adhere to permission checks (critical 9.8)
- [CVE-2026-22863](https://insights.sbomify.com/CVE-2026-22863/): Deno node:crypto doesn't finalize cipher (critical 9.2)
- [CVE-2024-27936](https://insights.sbomify.com/CVE-2024-27936/): Deno interactive permission prompt spoofing via improper ANSI stripping (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24015 and fix it if it is affected.

What it is: CVE-2025-24015 is a high-severity vulnerability in denoland deno, published on 3 Jun 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24015 exists.

Affected packages and fixed versions:
- deno (crates.io): affected from 1.46.0; fixed in 2.1.7
- deno (crates.io): affected from 1.46.0; fixed in 2.1.7
- deno_node (crates.io): affected from 0.102.0; fixed in 0.125.0
- deno_node (crates.io): affected from 0.102.0; fixed in 0.125.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24015/ (Markdown: https://insights.sbomify.com/CVE-2025-24015/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24015
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24015
- OSV: https://osv.dev/vulnerability/CVE-2025-24015

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24015/
Summaries are generated and may contain mistakes; the official description above is the record.
