CVE-2025-24017 YesWiki Vulnerable to Unauthenticated DOM Based XSS

High 7.6 Published Updated

An attacker can craft a malicious link exploiting DOM-based XSS in YesWiki to steal accounts and modify data when clicked.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2025-24017?

CVE-2025-24017 is a high-severity cross-site scripting vulnerability in yeswiki, published on 21 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

YesWiki is a wiki system written in PHP. Versions up to and including 4.4.5 are vulnerable to any end-user crafting a DOM based XSS on all of YesWiki's pages which is triggered when a user clicks on a malicious link. The vulnerability makes use of the search by tag feature. When a tag doesn't exist, the tag is reflected on the page and isn't properly sanitized on the server side which allows a malicious user to generate a link that will trigger an XSS on the client's side when clicked. This vulnerability allows any user to generate a malicious link that will trigger an account takeover when clicked, therefore allowing a user to steal other accounts, modify pages, comments, permissions, extract user data (emails), thus impacting the integrity, availability and confidentiality of a YesWiki instance. Version 4.5.0 contains a patch for the issue.

Weakness: CWE-79

Which versions are affected by CVE-2025-24017?

2 open source packages ship an affected version, including yeswiki/yeswiki. It affects 1 product.

PackageAffectedFixed in
yeswiki/yeswiki PackagistAll versions4.5.0
yeswiki/yeswiki PackagistAll versions4.5.0

Products include Yeswiki Yeswiki.

How do I fix CVE-2025-24017?

Upgrade yeswiki/yeswiki to 4.5.0 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2025-24017 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24017 exists.

Sources

Also known as GHSA-wphc-5f2j-jhvg.

Is CVE-2025-24017 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free