{"answers":{"affected":"2 open source packages ship an affected version, including yeswiki/yeswiki. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24017 exists.","fix":"Upgrade yeswiki/yeswiki to 4.5.0 or later.","what":"CVE-2025-24017 is a high-severity cross-site scripting vulnerability in yeswiki, published on 21 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2025-24017 and fix it if it is affected.\n\nWhat it is: CVE-2025-24017 is a high-severity cross-site scripting vulnerability in yeswiki, published on 21 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24017 exists.\n\nAffected packages and fixed versions:\n- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.5.0\n- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24017/ (Markdown: https://insights.sbomify.com/CVE-2025-24017/index.md)","id":"CVE-2025-24017","markdown":"https://insights.sbomify.com/CVE-2025-24017/index.md","name":"CVE-2025-24017","record":{"aliases":["GHSA-wphc-5f2j-jhvg"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read","data_modify"],"network_reachable":"yes","non_default_config":false,"product_category":"YesWiki","requires_auth":"none","summary":"An attacker can craft a malicious link exploiting DOM-based XSS in YesWiki to steal accounts and modify data when clicked.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"yeswiki","vendor":"yeswiki"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"YesWiki is a wiki system written in PHP. Versions up to and including 4.4.5 are vulnerable to any end-user crafting a DOM based XSS on all of YesWiki's pages which is triggered when a user clicks on a malicious link. The vulnerability makes use of the search by tag feature. When a tag doesn't exist, the tag is reflected on the page and isn't properly sanitized on the server side which allows a malicious user to generate a link that will trigger an XSS on the client's side when clicked. This vulnerability allows any user to generate a malicious link that will trigger an account takeover when clicked, therefore allowing a user to steal other accounts, modify pages, comments, permissions, extract user data (emails), thus impacting the integrity, availability and confidentiality of a YesWiki instance. Version 4.5.0 contains a patch for the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"YesWiki Vulnerable to Unauthenticated DOM Based XSS","id":"CVE-2025-24017","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"YesWiki Vulnerable to Authenticated Stored XSS","id":"CVE-2025-24018"},"packages":[{"ecosystem":"Packagist","fixed":["4.5.0"],"introduced":["0"],"last_affected":[],"package":"yeswiki/yeswiki","purl":null,"source":"GHSA-wphc-5f2j-jhvg"},{"ecosystem":"Packagist","fixed":["4.5.0"],"introduced":["0"],"last_affected":[],"package":"yeswiki/yeswiki","purl":"pkg:composer/yeswiki/yeswiki","source":"GHSA-wphc-5f2j-jhvg"}],"prev":{"headline":"Wazuh Server Deserialization of Untrusted Data","id":"CVE-2025-24016"},"products":["yeswiki"],"published":"2025-01-21","related":[{"cvss_score":10,"headline":"YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download","id":"CVE-2025-46348","kev_date_added":null,"published":"2025-04-29"},{"cvss_score":9.9,"headline":"Use of a Broken or Risky Cryptographic Algorithm in YesWiki","id":"CVE-2024-51478","kev_date_added":null,"published":"2024-10-31"},{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2018-1000641","kev_date_added":null,"published":"2018-08-20"},{"cvss_score":8.6,"headline":"Path Traversal allowing arbitrary read of files in Yeswiki","id":"CVE-2025-31131","kev_date_added":null,"published":"2025-04-01"},{"cvss_score":7.6,"headline":"YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting","id":"CVE-2025-46349","kev_date_added":null,"published":"2025-04-29"},{"cvss_score":7.6,"headline":"YesWiki Vulnerable to Authenticated Stored XSS","id":"CVE-2025-24018","kev_date_added":null,"published":"2025-01-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-12","vendors":["YesWiki"]},"summary":"An attacker can craft a malicious link exploiting DOM-based XSS in YesWiki to steal accounts and modify data when clicked.","url":"https://insights.sbomify.com/CVE-2025-24017/"}