# CVE-2025-24017: YesWiki Vulnerable to Unauthenticated DOM Based XSS

> An attacker can craft a malicious link exploiting DOM-based XSS in YesWiki to steal accounts and modify data when clicked.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 21 Jan 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-wphc-5f2j-jhvg

## What is CVE-2025-24017?

CVE-2025-24017 is a high-severity cross-site scripting vulnerability in yeswiki, published on 21 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

YesWiki is a wiki system written in PHP. Versions up to and including 4.4.5 are vulnerable to any end-user crafting a DOM based XSS on all of YesWiki's pages which is triggered when a user clicks on a malicious link. The vulnerability makes use of the search by tag feature. When a tag doesn't exist, the tag is reflected on the page and isn't properly sanitized on the server side which allows a malicious user to generate a link that will trigger an XSS on the client's side when clicked. This vulnerability allows any user to generate a malicious link that will trigger an account takeover when clicked, therefore allowing a user to steal other accounts, modify pages, comments, permissions, extract user data (emails), thus impacting the integrity, availability and confidentiality of a YesWiki instance. Version 4.5.0 contains a patch for the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-24017?

2 open source packages ship an affected version, including yeswiki/yeswiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions | 4.5.0 |
| `yeswiki/yeswiki` | Packagist | All versions | 4.5.0 |

Products: Yeswiki Yeswiki.

## How do I fix CVE-2025-24017?

Upgrade yeswiki/yeswiki to 4.5.0 or later.

## Is CVE-2025-24017 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24017 exists.

## Other vulnerabilities in yeswiki

- [CVE-2025-46348](https://insights.sbomify.com/CVE-2025-46348/): YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download (critical 10.0)
- [CVE-2024-51478](https://insights.sbomify.com/CVE-2024-51478/): Use of a Broken or Risky Cryptographic Algorithm in YesWiki (critical 9.9)
- [CVE-2018-1000641](https://insights.sbomify.com/CVE-2018-1000641/): Deserialization in n/a (critical 9.8)
- [CVE-2025-31131](https://insights.sbomify.com/CVE-2025-31131/): Path Traversal allowing arbitrary read of files in Yeswiki (high 8.6)
- [CVE-2025-46349](https://insights.sbomify.com/CVE-2025-46349/): YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24017 and fix it if it is affected.

What it is: CVE-2025-24017 is a high-severity cross-site scripting vulnerability in yeswiki, published on 21 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24017 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.5.0
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24017/ (Markdown: https://insights.sbomify.com/CVE-2025-24017/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24017
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24017
- OSV: https://osv.dev/vulnerability/CVE-2025-24017

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24017/
Summaries are generated and may contain mistakes; the official description above is the record.
