{"answers":{"affected":"2 open source packages ship an affected version, including yeswiki/yeswiki. It affects 1 product.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24018 exists.","fix":"Upgrade yeswiki/yeswiki to 4.5.0 or later.","what":"CVE-2025-24018 is a high-severity cross-site scripting vulnerability in yeswiki, published on 21 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-24018 and fix it if it is affected.\n\nWhat it is: CVE-2025-24018 is a high-severity cross-site scripting vulnerability in yeswiki, published on 21 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24018 exists.\n\nAffected packages and fixed versions:\n- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.5.0\n- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24018/ (Markdown: https://insights.sbomify.com/CVE-2025-24018/index.md)","id":"CVE-2025-24018","markdown":"https://insights.sbomify.com/CVE-2025-24018/index.md","name":"CVE-2025-24018","record":{"aliases":["GHSA-w59h-3x3q-3p6j"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["account_takeover","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"YesWiki wiki system","requires_auth":"low_privilege","summary":"Authenticated users can inject malicious scripts via the file attachment feature, leading to account takeover and data theft in YesWiki instances.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"yeswiki","vendor":"yeswiki"}],"cvss":{"score":7.6,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"YesWiki is a wiki system written in PHP. In versions up to and including 4.4.5, it is possible for an authenticated user with rights to edit/create a page or comment to trigger a stored XSS which will be reflected on any page where the resource is loaded. The vulnerability makes use of the content edition feature and more specifically of the `{{attach}}` component allowing users to attach files/medias to a page. When a file is attached using the `{{attach}}` component, if the resource contained in the `file` attribute doesn't exist, then the server will generate a file upload button containing the filename. This vulnerability allows any malicious authenticated user that has the right to create a comment or edit a page to be able to steal accounts and therefore modify pages, comments, permissions, extract user data (emails), thus impacting the integrity, availability and confidentiality of a YesWiki instance. Version 4.5.0 contains a patch for the issue.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"YesWiki Vulnerable to Authenticated Stored XSS","id":"CVE-2025-24018","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"YesWiki vulnerable to authenticated arbitrary file deletion","id":"CVE-2025-24019"},"packages":[{"ecosystem":"Packagist","fixed":["4.5.0"],"introduced":["0"],"last_affected":[],"package":"yeswiki/yeswiki","purl":null,"source":"GHSA-w59h-3x3q-3p6j"},{"ecosystem":"Packagist","fixed":["4.5.0"],"introduced":["0"],"last_affected":[],"package":"yeswiki/yeswiki","purl":"pkg:composer/yeswiki/yeswiki","source":"GHSA-w59h-3x3q-3p6j"}],"prev":{"headline":"YesWiki Vulnerable to Unauthenticated DOM Based XSS","id":"CVE-2025-24017"},"products":["yeswiki"],"published":"2025-01-21","related":[{"cvss_score":10,"headline":"YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download","id":"CVE-2025-46348","kev_date_added":null,"published":"2025-04-29"},{"cvss_score":9.9,"headline":"Use of a Broken or Risky Cryptographic Algorithm in YesWiki","id":"CVE-2024-51478","kev_date_added":null,"published":"2024-10-31"},{"cvss_score":9.8,"headline":"Deserialization in n/a","id":"CVE-2018-1000641","kev_date_added":null,"published":"2018-08-20"},{"cvss_score":8.6,"headline":"Path Traversal allowing arbitrary read of files in Yeswiki","id":"CVE-2025-31131","kev_date_added":null,"published":"2025-04-01"},{"cvss_score":7.6,"headline":"YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting","id":"CVE-2025-46349","kev_date_added":null,"published":"2025-04-29"},{"cvss_score":7.6,"headline":"YesWiki Vulnerable to Unauthenticated DOM Based XSS","id":"CVE-2025-24017","kev_date_added":null,"published":"2025-01-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-21","vendors":["YesWiki"]},"summary":"Authenticated users can inject malicious scripts via the file attachment feature, leading to account takeover and data theft in YesWiki instances.","url":"https://insights.sbomify.com/CVE-2025-24018/"}