# CVE-2025-24018: YesWiki Vulnerable to Authenticated Stored XSS

> Authenticated users can inject malicious scripts via the file attachment feature, leading to account takeover and data theft in YesWiki instances.

- **Severity:** High 7.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:H/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jan 2025
- **Updated:** 21 Jan 2025
- **Also known as:** GHSA-w59h-3x3q-3p6j

## What is CVE-2025-24018?

CVE-2025-24018 is a high-severity cross-site scripting vulnerability in yeswiki, published on 21 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

YesWiki is a wiki system written in PHP. In versions up to and including 4.4.5, it is possible for an authenticated user with rights to edit/create a page or comment to trigger a stored XSS which will be reflected on any page where the resource is loaded. The vulnerability makes use of the content edition feature and more specifically of the `{{attach}}` component allowing users to attach files/medias to a page. When a file is attached using the `{{attach}}` component, if the resource contained in the `file` attribute doesn't exist, then the server will generate a file upload button containing the filename. This vulnerability allows any malicious authenticated user that has the right to create a comment or edit a page to be able to steal accounts and therefore modify pages, comments, permissions, extract user data (emails), thus impacting the integrity, availability and confidentiality of a YesWiki instance. Version 4.5.0 contains a patch for the issue.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-24018?

2 open source packages ship an affected version, including yeswiki/yeswiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions | 4.5.0 |
| `yeswiki/yeswiki` | Packagist | All versions | 4.5.0 |

Products: Yeswiki Yeswiki.

## How do I fix CVE-2025-24018?

Upgrade yeswiki/yeswiki to 4.5.0 or later.

## Is CVE-2025-24018 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24018 exists.

## Other vulnerabilities in yeswiki

- [CVE-2025-46348](https://insights.sbomify.com/CVE-2025-46348/): YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download (critical 10.0)
- [CVE-2024-51478](https://insights.sbomify.com/CVE-2024-51478/): Use of a Broken or Risky Cryptographic Algorithm in YesWiki (critical 9.9)
- [CVE-2018-1000641](https://insights.sbomify.com/CVE-2018-1000641/): Deserialization in n/a (critical 9.8)
- [CVE-2025-31131](https://insights.sbomify.com/CVE-2025-31131/): Path Traversal allowing arbitrary read of files in Yeswiki (high 8.6)
- [CVE-2025-46349](https://insights.sbomify.com/CVE-2025-46349/): YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24018 and fix it if it is affected.

What it is: CVE-2025-24018 is a high-severity cross-site scripting vulnerability in yeswiki, published on 21 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24018 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.5.0
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24018/ (Markdown: https://insights.sbomify.com/CVE-2025-24018/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24018
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24018
- OSV: https://osv.dev/vulnerability/CVE-2025-24018

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24018/
Summaries are generated and may contain mistakes; the official description above is the record.
