# CVE-2025-24019: YesWiki vulnerable to authenticated arbitrary file deletion

> Authenticated users can delete arbitrary files via the filemanager, causing data loss or site defacement in YesWiki.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Jan 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-43c9-gw4x-pcx6

## What is CVE-2025-24019?

CVE-2025-24019 is a high-severity path traversal vulnerability in yeswiki, published on 21 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

YesWiki is a wiki system written in PHP. In versions up to and including 4.4.5, it is possible for any authenticated user, through the use of the filemanager to delete any file owned by the user running the FastCGI Process Manager (FPM) on the host without any limitation on the filesystem's scope. This vulnerability allows any authenticated user to arbitrarily remove content from the Wiki resulting in partial loss of data and defacement/deterioration of the website. In the context of a container installation of YesWiki without any modification, the `yeswiki` files (for example .php) are not owned by the same user (root) as the one running the FPM process (www-data). However in a standard installation, www-data may also be the owner of the PHP files, allowing a malicious user to completely cut the access to the wiki by deleting all important PHP files (like index.php or core files of YesWiki). Version 4.5.0 contains a patch for this issue.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2025-24019?

2 open source packages ship an affected version, including yeswiki/yeswiki. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `yeswiki/yeswiki` | Packagist | All versions | 4.5.0 |
| `yeswiki/yeswiki` | Packagist | All versions | 4.5.0 |

Products: Yeswiki Yeswiki.

## How do I fix CVE-2025-24019?

Upgrade yeswiki/yeswiki to 4.5.0 or later.

## Is CVE-2025-24019 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24019 exists.

## Other vulnerabilities in yeswiki

- [CVE-2025-46348](https://insights.sbomify.com/CVE-2025-46348/): YesWiki Vulnerable to Unauthenticated Site Backup Creation and Download (critical 10.0)
- [CVE-2024-51478](https://insights.sbomify.com/CVE-2024-51478/): Use of a Broken or Risky Cryptographic Algorithm in YesWiki (critical 9.9)
- [CVE-2018-1000641](https://insights.sbomify.com/CVE-2018-1000641/): Deserialization in n/a (critical 9.8)
- [CVE-2025-31131](https://insights.sbomify.com/CVE-2025-31131/): Path Traversal allowing arbitrary read of files in Yeswiki (high 8.6)
- [CVE-2025-46349](https://insights.sbomify.com/CVE-2025-46349/): YesWiki Vulnerable to Unauthenticated Reflected Cross-site Scripting (high 7.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24019 and fix it if it is affected.

What it is: CVE-2025-24019 is a high-severity path traversal vulnerability in yeswiki, published on 21 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24019 exists.

Affected packages and fixed versions:
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.5.0
- yeswiki/yeswiki (Packagist): affected all versions; fixed in 4.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24019/ (Markdown: https://insights.sbomify.com/CVE-2025-24019/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24019
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24019
- OSV: https://osv.dev/vulnerability/CVE-2025-24019

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24019/
Summaries are generated and may contain mistakes; the official description above is the record.
