CVE-2025-24022 iTop server vulnerable to portal code injection
Attackers can execute arbitrary server code via the iTop portal frontend, requiring an upgrade to patched versions.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2025-24022?
CVE-2025-24022 is a high-severity code injection vulnerability in Combodo Itop, published on 14 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
iTop is an web based IT Service Management tool. Prior to versions 2.7.12, 3.1.3, and 3.2.1, server code execution is possible through the frontend of iTop's portal. This is fixed in versions 2.7.12, 3.1.3 and 3.2.1.
Weakness: CWE-78
Which versions are affected by CVE-2025-24022?
It affects 1 product.
Products include Combodo Itop.
How do I fix CVE-2025-24022?
No fix has been published for CVE-2025-24022 yet. Limit exposure of the affected software until one is available.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2025-24022 being exploited?
There is no known exploitation of CVE-2025-24022 in the wild and no public exploit code.
Other vulnerabilities in Combodo Itop
- CVE-2023-48710 iTop limit pages/exec.php script to PHP files
- CVE-2022-39214 Authenticated users of Combodo iTop can take over any account
- CVE-2021-41161 XSS in csvimport in 3.0.0-beta versions
- CVE-2021-41162 Cross-site Scripting in Combodo iTop
- CVE-2025-47773 Combodo iTop has XSS vulnerability in /pages/ajax.render.php
Sources
Also known as GHSA-rhv2-wfrr-4j2j.