# CVE-2025-24022: iTop server vulnerable to portal code injection

> Attackers can execute arbitrary server code via the iTop portal frontend, requiring an upgrade to patched versions.

- **Severity:** High 8.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 14 May 2025
- **Updated:** 20 Jan 2026
- **Also known as:** GHSA-rhv2-wfrr-4j2j

## What is CVE-2025-24022?

CVE-2025-24022 is a high-severity code injection vulnerability in Combodo Itop, published on 14 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

iTop is an web based IT Service Management tool. Prior to versions 2.7.12, 3.1.3, and 3.2.1, server code execution is possible through the frontend of iTop's portal. This is fixed in versions 2.7.12, 3.1.3 and 3.2.1.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2025-24022?

It affects 1 product.


Products: Combodo Itop.

## How do I fix CVE-2025-24022?

No fix has been published for CVE-2025-24022 yet. Limit exposure of the affected software until one is available.

## Is CVE-2025-24022 being exploited?

There is no known exploitation of CVE-2025-24022 in the wild and no public exploit code.

## Other vulnerabilities in Combodo Itop

- [CVE-2023-48710](https://insights.sbomify.com/CVE-2023-48710/): iTop limit pages/exec.php script to PHP files (critical 9.8)
- [CVE-2022-39214](https://insights.sbomify.com/CVE-2022-39214/): Authenticated users of Combodo iTop can take over any account (critical 9.6)
- [CVE-2021-41161](https://insights.sbomify.com/CVE-2021-41161/): XSS in csvimport in 3.0.0-beta versions (critical 9.3)
- [CVE-2021-41162](https://insights.sbomify.com/CVE-2021-41162/): Cross-site Scripting in Combodo iTop (critical 9.3)
- [CVE-2025-47773](https://insights.sbomify.com/CVE-2025-47773/): Combodo iTop has XSS vulnerability in /pages/ajax.render.php (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24022 and fix it if it is affected.

What it is: CVE-2025-24022 is a high-severity code injection vulnerability in Combodo Itop, published on 14 May 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24022 in the wild and no public exploit code.

Affected product: Combodo Itop. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24022/ (Markdown: https://insights.sbomify.com/CVE-2025-24022/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24022
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24022
- OSV: https://osv.dev/vulnerability/CVE-2025-24022

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24022/
Summaries are generated and may contain mistakes; the official description above is the record.
