# CVE-2025-24023: Observable Response Discrepancy in flask-appbuilder

> Unauthenticated attackers can enumerate valid usernames by analyzing response timing discrepancies during login attempts in Flask-AppBuilder.

- **Severity:** Low 3.7 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Mar 2025
- **Updated:** 3 Mar 2025
- **Also known as:** CLEANSTART-2026-KC19825, CLEANSTART-2026-LB63084, ECHO-04ff-1109-61d3, GHSA-p8q5-cvwx-wvwp, PYSEC-2025-15

## What is CVE-2025-24023?

CVE-2025-24023 is a low-severity vulnerability in dpgaspar Flask-AppBuilder, published on 3 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Flask-AppBuilder is an application development framework. Prior to 4.5.3, Flask-AppBuilder allows unauthenticated users to enumerate existing usernames by timing the response time from the server when brute forcing requests to login. This vulnerability is fixed in 4.5.3.

Weakness: CWE-203 (Observable Discrepancy), CWE-204 (Observable Response Discrepancy)

## Which versions are affected by CVE-2025-24023?

3 open source packages ship an affected version, including flask-appbuilder. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `flask-appbuilder` | PyPI | All versions | 4.5.3 |
| `flask-appbuilder` | PyPI | All versions | 4.5.3 |
| `flask-appbuilder` | PyPI | All versions | 4.5.3 |

Products: Dpgaspar Flask-Appbuilder.

## How do I fix CVE-2025-24023?

Upgrade flask-appbuilder to 4.5.3 or later.

## Is CVE-2025-24023 being exploited?

There is no known exploitation of CVE-2025-24023 in the wild and no public exploit code.

## Other vulnerabilities in dpgaspar Flask-AppBuilder

- [CVE-2024-25128](https://insights.sbomify.com/CVE-2024-25128/): Flask-AppBuilder incorrect authentication when using auth type OpenID (critical 9.1)
- [CVE-2021-41265](https://insights.sbomify.com/CVE-2021-41265/): Improper Authentication in Flask-AppBuilder (high 8.1)
- [CVE-2023-29005](https://insights.sbomify.com/CVE-2023-29005/): No Rate Limiting on Login AUTH DB (high 7.5)
- [CVE-2021-32805](https://insights.sbomify.com/CVE-2021-32805/): URL Redirection to Untrusted Site ('Open Redirect') in Flask-AppBuilder (high 7.2)
- [CVE-2025-58065](https://insights.sbomify.com/CVE-2025-58065/): Flask App Builder has an Authentication Bypass vulnerability when using non AUTH_DB methods (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24023 and fix it if it is affected.

What it is: CVE-2025-24023 is a low-severity vulnerability in dpgaspar Flask-AppBuilder, published on 3 Mar 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24023 in the wild and no public exploit code.

Affected packages and fixed versions:
- flask-appbuilder (PyPI): affected all versions; fixed in 4.5.3
- flask-appbuilder (PyPI): affected all versions; fixed in 4.5.3
- flask-appbuilder (PyPI): affected all versions; fixed in 4.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24023/ (Markdown: https://insights.sbomify.com/CVE-2025-24023/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24023
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24023
- OSV: https://osv.dev/vulnerability/CVE-2025-24023

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24023/
Summaries are generated and may contain mistakes; the official description above is the record.
