{"answers":{"affected":"2 open source packages ship an affected version, including prestashop/ps_contactinfo.","exploited":"There is no known exploitation of CVE-2025-24027 in the wild and no public exploit code.","fix":"Upgrade prestashop/ps_contactinfo to 3.3.3 or later.","what":"CVE-2025-24027 is a medium-severity cross-site scripting vulnerability in PrestaShop ps_contactinfo, published on 22 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-24027 and fix it if it is affected.\n\nWhat it is: CVE-2025-24027 is a medium-severity cross-site scripting vulnerability in PrestaShop ps_contactinfo, published on 22 Jan 2025. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-24027 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- prestashop/ps_contactinfo (Packagist): affected all versions; fixed in 3.3.3\n- prestashop/ps_contactinfo (Packagist): affected all versions; fixed in 3.3.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24027/ (Markdown: https://insights.sbomify.com/CVE-2025-24027/index.md)","id":"CVE-2025-24027","markdown":"https://insights.sbomify.com/CVE-2025-24027/index.md","name":"CVE-2025-24027","record":{"aliases":["GHSA-35pq-7pv2-2rfw"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"PrestaShop module","requires_auth":"high_privilege","summary":"Stored XSS in PrestaShop contact info module allows attackers to execute scripts if data is compromised by other vulnerable modules.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":6.2,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:H/UI:N/S:U/C:H/I:L/A:H","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"ps_contactinfo, a PrestaShop module for displaying store contact information, has a cross-site scripting (XSS) vulnerability in versions up to and including 3.3.2. This can not be exploited in a fresh install of PrestaShop, only shops made vulnerable by third party modules are concerned. For example, if the shop has a third party module vulnerable to SQL injections, then ps_contactinfo might execute a stored cross-site scripting in formatting objects. Commit d60f9a5634b4fc2d3a8831fb08fe2e1f23cbfa39 keeps formatted addresses from displaying a XSS stored in the database, and the fix is expected to be available in version 3.3.3. No workarounds are available aside from applying the fix and keeping all modules maintained and update.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ps_contactinfo has potential XSS due to usage of the nofilter tag in template","id":"CVE-2025-24027","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":2,"n_references":2,"next":{"headline":"Cross-site Scripting (XSS) in Rich Text Editor allows arbitrary code execution in Joplin","id":"CVE-2025-24028"},"packages":[{"ecosystem":"Packagist","fixed":["3.3.3"],"introduced":["0"],"last_affected":[],"package":"prestashop/ps_contactinfo","purl":null,"source":"GHSA-35pq-7pv2-2rfw"},{"ecosystem":"Packagist","fixed":["3.3.3"],"introduced":["0"],"last_affected":[],"package":"prestashop/ps_contactinfo","purl":"pkg:composer/prestashop/ps_contactinfo","source":"GHSA-35pq-7pv2-2rfw"}],"prev":{"headline":"iTop Inefficient Regular Expression Complexity vulnerability","id":"CVE-2025-24026"},"products":["ps_contactinfo"],"published":"2025-01-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2025-02-12","vendors":["PrestaShop"]},"summary":"Stored XSS in PrestaShop contact info module allows attackers to execute scripts if data is compromised by other vulnerable modules.","url":"https://insights.sbomify.com/CVE-2025-24027/"}