{"answers":{"affected":"4 open source packages ship an affected version, including github.com/envoyproxy/gateway and envoy-gateway. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-24030 in the wild and no public exploit code.","fix":"Upgrade github.com/envoyproxy/gateway to 1.2.6 or later.","what":"CVE-2025-24030 is a high-severity path traversal vulnerability in envoyproxy gateway, published on 23 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-24030 and fix it if it is affected.\n\nWhat it is: CVE-2025-24030 is a high-severity path traversal vulnerability in envoyproxy gateway, published on 23 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-24030 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.2.6\n- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.2.6\n- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.2.6\n- envoy-gateway (Bitnami): affected all versions; fixed in 1.2.6\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24030/ (Markdown: https://insights.sbomify.com/CVE-2025-24030/index.md)","id":"CVE-2025-24030","markdown":"https://insights.sbomify.com/CVE-2025-24030/index.md","name":"CVE-2025-24030","record":{"aliases":["BIT-envoy-gateway-2025-24030","GHSA-j777-63hf-hx76","GO-2025-3418"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Envoy Gateway","requires_auth":"none","summary":"A path traversal vulnerability in Envoy Gateway allows cluster users to access the admin interface, potentially exposing configuration data or terminating processes.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"gateway","vendor":"envoyproxy"}],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-419","name":"Unprotected Primary Channel"}],"description":"Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. A user with access to the Kubernetes cluster can use a path traversal attack to execute Envoy Admin interface commands on proxies managed by any version of Envoy Gateway prior to 1.2.6. The admin interface can be used to terminate the Envoy process and extract the Envoy configuration (possibly containing confidential data). Version 1.2.6 fixes the issue. As a workaround, the `EnvoyProxy` API can be used to apply a bootstrap config patch that restricts access strictly to the prometheus stats endpoint. Find below an example of such a bootstrap patch.","ecosystems":["Bitnami","Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Envoy Admin Interface Exposed through prometheus metrics endpoint","id":"CVE-2025-24030","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"path_traversal","year":"2025"},"n_packages":4,"n_references":4,"next":{"headline":"PAM-PKCS#11 vulnerable to segmentation fault on ctrl-c/ctrl-d when asked for PIN","id":"CVE-2025-24031"},"packages":[{"ecosystem":"Bitnami","fixed":["1.2.6"],"introduced":["0"],"last_affected":[],"package":"envoy-gateway","purl":"pkg:bitnami/envoy-gateway","source":"BIT-envoy-gateway-2025-24030"},{"ecosystem":"Go","fixed":["1.2.6"],"introduced":["0"],"last_affected":[],"package":"github.com/envoyproxy/gateway","purl":null,"source":"GHSA-j777-63hf-hx76"},{"ecosystem":"Go","fixed":["1.2.6"],"introduced":["0"],"last_affected":[],"package":"github.com/envoyproxy/gateway","purl":"pkg:golang/github.com/envoyproxy/gateway","source":"GHSA-j777-63hf-hx76"},{"ecosystem":"Go","fixed":["1.2.6"],"introduced":["0"],"last_affected":[],"package":"github.com/envoyproxy/gateway","purl":"pkg:golang/github.com/envoyproxy/gateway","source":"GO-2025-3418"}],"prev":{"headline":"Artifact permissions are not verified in the Cross Tracker Search widget in Tuleap","id":"CVE-2025-24029"},"products":["gateway"],"published":"2025-01-23","related":[{"cvss_score":8.8,"headline":"Envoy Extension Policy lua scripts injection causes arbitrary command execution","id":"CVE-2026-22771","kev_date_added":null,"published":"2026-01-12"},{"cvss_score":5.3,"headline":"Envoy Gateway Log Injection Vulnerability","id":"CVE-2025-25294","kev_date_added":null,"published":"2025-03-06"}],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-01-23","vendors":["envoyproxy"]},"summary":"A path traversal vulnerability in Envoy Gateway allows cluster users to access the admin interface, potentially exposing configuration data or terminating processes.","url":"https://insights.sbomify.com/CVE-2025-24030/"}