# CVE-2025-24030: Envoy Admin Interface Exposed through prometheus metrics endpoint

> A path traversal vulnerability in Envoy Gateway allows cluster users to access the admin interface, potentially exposing configuration data or terminating processes.

- **Severity:** High 7.1 (`CVSS:3.1/AV:A/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2025
- **Updated:** 23 Jan 2025
- **Also known as:** BIT-envoy-gateway-2025-24030, GHSA-j777-63hf-hx76, GO-2025-3418

## What is CVE-2025-24030?

CVE-2025-24030 is a high-severity path traversal vulnerability in envoyproxy gateway, published on 23 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Envoy Gateway is an open source project for managing Envoy Proxy as a standalone or Kubernetes-based application gateway. A user with access to the Kubernetes cluster can use a path traversal attack to execute Envoy Admin interface commands on proxies managed by any version of Envoy Gateway prior to 1.2.6. The admin interface can be used to terminate the Envoy process and extract the Envoy configuration (possibly containing confidential data). Version 1.2.6 fixes the issue. As a workaround, the `EnvoyProxy` API can be used to apply a bootstrap config patch that restricts access strictly to the prometheus stats endpoint. Find below an example of such a bootstrap patch.

Weakness: CWE-419 (Unprotected Primary Channel)

## Which versions are affected by CVE-2025-24030?

4 open source packages ship an affected version, including github.com/envoyproxy/gateway and envoy-gateway. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.2.6 |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.2.6 |
| `github.com/envoyproxy/gateway` | Go | All versions | 1.2.6 |
| `envoy-gateway` | Bitnami | All versions | 1.2.6 |

Products: Envoyproxy Gateway.

## How do I fix CVE-2025-24030?

Upgrade github.com/envoyproxy/gateway to 1.2.6 or later.

## Is CVE-2025-24030 being exploited?

There is no known exploitation of CVE-2025-24030 in the wild and no public exploit code.

## Other vulnerabilities in envoyproxy gateway

- [CVE-2026-22771](https://insights.sbomify.com/CVE-2026-22771/): Envoy Extension Policy lua scripts injection causes arbitrary command execution (high 8.8)
- [CVE-2025-25294](https://insights.sbomify.com/CVE-2025-25294/): Envoy Gateway Log Injection Vulnerability (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24030 and fix it if it is affected.

What it is: CVE-2025-24030 is a high-severity path traversal vulnerability in envoyproxy gateway, published on 23 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24030 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.2.6
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.2.6
- github.com/envoyproxy/gateway (Go): affected all versions; fixed in 1.2.6
- envoy-gateway (Bitnami): affected all versions; fixed in 1.2.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24030/ (Markdown: https://insights.sbomify.com/CVE-2025-24030/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24030
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24030
- OSV: https://osv.dev/vulnerability/CVE-2025-24030

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24030/
Summaries are generated and may contain mistakes; the official description above is the record.
