CVE-2025-2424 Leaked Metadata of Deleted Files via Bookmark Creation

Low 3.1 Published Updated

Attackers can retrieve metadata of deleted files by creating bookmarks, exposing sensitive information in Mattermost deployments.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2025-2424?

CVE-2025-2424 is a low-severity vulnerability in Mattermost Mattermost Server, published on 14 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

Mattermost versions 10.5.x <= 10.5.1, 9.11.x <= 9.11.9 fail to check if a file has been deleted when creating a bookmark which allows an attacker who knows the IDs of deleted files to obtain metadata of the files via bookmark creation.

Weakness: CWE-863

Which versions are affected by CVE-2025-2424?

10 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.

PackageAffectedFixed in
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250213231113-68c11e9ecb71
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250213231113-68c11e9ecb71
github.com/mattermost/mattermost/server/v8 GoAll versions8.0.0-20250213231113-68c11e9ecb71
github.com/mattermost/mattermost/server/v8 GoFrom 10.5.010.5.2
github.com/mattermost/mattermost/server/v8 GoFrom 10.5.010.5.2
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.10
4 more packages
github.com/mattermost/mattermost/server/v8 GoFrom 9.11.09.11.10
github.com/mattermost/mattermost-server GoFrom 9.11.0+incompatible9.11.10+incompatible, 10.5.2+incompatible
github.com/mattermost/mattermost-server/v5 GoAll versionsNone
github.com/mattermost/mattermost-server/v6 GoAll versionsNone

Products include Mattermost Mattermost Server.

How do I fix CVE-2025-2424?

Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250213231113-68c11e9ecb71, 10.5.2 or 9.11.10.

Is CVE-2025-2424 being exploited?

There is no known exploitation of CVE-2025-2424 in the wild and no public exploit code.

All Mattermost Mattermost Server vulnerabilities

Sources

Also known as GHSA-wwhj-pw6h-f8hw, GO-2025-3611.

Is CVE-2025-2424 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free