CVE-2025-24354 imgproxy is vulnerable to SSRF against 0.0.0.0

Medium 5.3 Published Updated
Exploited in the wild
Not known
Fix
Available

What is CVE-2025-24354?

CVE-2025-24354 is a medium-severity vulnerability in imgproxy, published on 27 Jan 2025.

Official description

imgproxy is server for resizing, processing, and converting images. Imgproxy does not block the 0.0.0.0 address, even with IMGPROXY_ALLOW_LOOPBACK_SOURCE_ADDRESSES set to false. This can expose services on the local host. This vulnerability is fixed in 3.27.2.

Weakness: CWE-918

Which versions are affected by CVE-2025-24354?

5 open source packages ship an affected version, including github.com/imgproxy/imgproxy, github.com/imgproxy/imgproxy/v2 and github.com/imgproxy/imgproxy/v3.

PackageAffectedFixed in
github.com/imgproxy/imgproxy GoAll versionsNone
github.com/imgproxy/imgproxy GoAll versions3.27.2
github.com/imgproxy/imgproxy GoAll versions3.27.2
github.com/imgproxy/imgproxy/v2 GoAll versionsNone
github.com/imgproxy/imgproxy/v3 GoAll versions3.27.2

How do I fix CVE-2025-24354?

Upgrade github.com/imgproxy/imgproxy to 3.27.2 or later.

Is CVE-2025-24354 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24354 exists.

Public exploit code: 1 Nuclei template and 1 proofs of concept on GitHub.

Sources

Also known as GHSA-j2hp-6m75-v4j4, GO-2025-3422.

Is CVE-2025-24354 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free