# CVE-2025-24354: imgproxy is vulnerable to SSRF against 0.0.0.0


- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 Jan 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-j2hp-6m75-v4j4, GO-2025-3422

## What is CVE-2025-24354?

CVE-2025-24354 is a medium-severity vulnerability in imgproxy, published on 27 Jan 2025. 

### Official description

imgproxy is server for resizing, processing, and converting images. Imgproxy does not block the 0.0.0.0 address, even with IMGPROXY_ALLOW_LOOPBACK_SOURCE_ADDRESSES set to false. This can expose services on the local host. This vulnerability is fixed in 3.27.2.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2025-24354?

5 open source packages ship an affected version, including github.com/imgproxy/imgproxy, github.com/imgproxy/imgproxy/v2 and github.com/imgproxy/imgproxy/v3.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/imgproxy/imgproxy` | Go | All versions | None |
| `github.com/imgproxy/imgproxy` | Go | All versions | 3.27.2 |
| `github.com/imgproxy/imgproxy` | Go | All versions | 3.27.2 |
| `github.com/imgproxy/imgproxy/v2` | Go | All versions | None |
| `github.com/imgproxy/imgproxy/v3` | Go | All versions | 3.27.2 |

## How do I fix CVE-2025-24354?

Upgrade github.com/imgproxy/imgproxy to 3.27.2 or later.

## Is CVE-2025-24354 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24354 exists.

Public exploit code:

- SSRF in ImgProxy (only for educational purpose) (github_poc): https://github.com/Admin9961/CVE-2025-24354-PoC
- Imgproxy < 3.27.2 - Server-Side Request Forgery (SSRF) (nuclei): http/cves/2025/CVE-2025-24354.yaml

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24354 and fix it if it is affected.

What it is: CVE-2025-24354 is a medium-severity vulnerability in imgproxy, published on 27 Jan 2025. 
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24354 exists.

Affected packages and fixed versions:
- github.com/imgproxy/imgproxy (Go): affected all versions; no fix listed
- github.com/imgproxy/imgproxy (Go): affected all versions; fixed in 3.27.2
- github.com/imgproxy/imgproxy (Go): affected all versions; fixed in 3.27.2
- github.com/imgproxy/imgproxy/v2 (Go): affected all versions; no fix listed
- github.com/imgproxy/imgproxy/v3 (Go): affected all versions; fixed in 3.27.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24354/ (Markdown: https://insights.sbomify.com/CVE-2025-24354/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24354
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24354
- OSV: https://osv.dev/vulnerability/CVE-2025-24354

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24354/
Summaries are generated and may contain mistakes; the official description above is the record.
