{"answers":{"affected":"3 open source packages ship an affected version, including github.com/updatecli/updatecli.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24355 exists.","fix":"Upgrade github.com/updatecli/updatecli to 0.93.0 or later.","what":"CVE-2025-24355 is a high-severity vulnerability in updatecli, published on 24 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-24355 and fix it if it is affected.\n\nWhat it is: CVE-2025-24355 is a high-severity vulnerability in updatecli, published on 24 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24355 exists.\n\nAffected packages and fixed versions:\n- github.com/updatecli/updatecli (Go): affected all versions; fixed in 0.93.0\n- github.com/updatecli/updatecli (Go): affected all versions; fixed in 0.93.0\n- github.com/updatecli/updatecli (Go): affected all versions; fixed in 0.93.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24355/ (Markdown: https://insights.sbomify.com/CVE-2025-24355/index.md)","id":"CVE-2025-24355","markdown":"https://insights.sbomify.com/CVE-2025-24355/index.md","name":"CVE-2025-24355","record":{"aliases":["GHSA-v34r-vj4r-38j6","GO-2025-3419"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Go update tool","requires_auth":"none","summary":"Updatecli leaks Maven credentials in logs during failed retrieval operations, exposing sensitive authentication data to anyone with log access.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:3.0/AV:L/AC:L/PR:N/UI:N/S:C/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-359","name":"Exposure of Private Personal Information to an Unauthorized Actor"}],"description":"Updatecli is a tool used to apply file update strategies. Prior to version 0.93.0, private maven repository credentials may be leaked in application logs in case of unsuccessful retrieval operation. During the execution of an updatecli pipeline which contains a `maven` source configured with basic auth credentials, the credentials are being leaked in the application execution logs in case of failure. Credentials are properly sanitized when the operation is successful but not when for whatever reason there is a failure in the maven repository, e.g. wrong coordinates provided, not existing artifact or version. Version 0.93.0 contains a patch for the issue.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Updatecli may expose Maven credentials in console output","id":"CVE-2025-24355","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"information_disclosure","year":"2025"},"n_packages":3,"n_references":2,"next":{"headline":"UDP traffic amplification via fastd's fast reconnect feature","id":"CVE-2025-24356"},"packages":[{"ecosystem":"Go","fixed":["0.93.0"],"introduced":["0"],"last_affected":[],"package":"github.com/updatecli/updatecli","purl":null,"source":"GHSA-v34r-vj4r-38j6"},{"ecosystem":"Go","fixed":["0.93.0"],"introduced":["0"],"last_affected":[],"package":"github.com/updatecli/updatecli","purl":"pkg:golang/github.com/updatecli/updatecli","source":"GHSA-v34r-vj4r-38j6"},{"ecosystem":"Go","fixed":["0.93.0"],"introduced":["0"],"last_affected":[],"package":"github.com/updatecli/updatecli","purl":"pkg:golang/github.com/updatecli/updatecli","source":"GO-2025-3419"}],"prev":{"headline":"imgproxy is vulnerable to SSRF against 0.0.0.0","id":"CVE-2025-24354"},"products":["updatecli"],"published":"2025-01-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-02-12","vendors":["updatecli"]},"summary":"Updatecli leaks Maven credentials in logs during failed retrieval operations, exposing sensitive authentication data to anyone with log access.","url":"https://insights.sbomify.com/CVE-2025-24355/"}