# CVE-2025-24357: vLLM allows a malicious model RCE by torch.load in hf_model_weights_iterator

> Attackers can execute arbitrary code by providing malicious model checkpoints to vLLM due to unsafe pickle deserialization in weight loading.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Jan 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-rh4j-5rhw-hr54, PYSEC-2025-58

## What is CVE-2025-24357?

CVE-2025-24357 is a high-severity unsafe deserialization vulnerability in Vllm Vllm, published on 27 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

vLLM is a library for LLM inference and serving. vllm/model_executor/weight_utils.py implements hf_model_weights_iterator to load the model checkpoint, which is downloaded from huggingface. It uses the torch.load function and the weights_only parameter defaults to False. When torch.load loads malicious pickle data, it will execute arbitrary code during unpickling. This vulnerability is fixed in v0.7.0.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2025-24357?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.7.0 |
| `vllm` | PyPI | All versions | 0.7.0 |
| `vllm` | PyPI | All versions | 0.7.0 |

Products: Vllm Vllm.

## How do I fix CVE-2025-24357?

Upgrade vllm to 0.7.0 or later.

## Is CVE-2025-24357 being exploited?

There is no known exploitation of CVE-2025-24357 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24357 and fix it if it is affected.

What it is: CVE-2025-24357 is a high-severity unsafe deserialization vulnerability in Vllm Vllm, published on 27 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-24357 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.7.0
- vllm (PyPI): affected all versions; fixed in 0.7.0
- vllm (PyPI): affected all versions; fixed in 0.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24357/ (Markdown: https://insights.sbomify.com/CVE-2025-24357/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24357
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24357
- OSV: https://osv.dev/vulnerability/CVE-2025-24357

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24357/
Summaries are generated and may contain mistakes; the official description above is the record.
