# CVE-2025-24360: Opening a malicious website while running a Nuxt dev server could allow read-only access to code

> A malicious website can steal source code from a running Nuxt development server due to permissive default CORS settings.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jan 2025
- **Updated:** 12 Feb 2025
- **Also known as:** CLSA-2026-1776040400, CLSA-2026-1792161444, CLSA-2026-1792161585, CLSA-2026-1792161808, CLSA-2026-1792161921, CLSA-2026-1792232953, GHSA-2452-6xj8-jh47

## What is CVE-2025-24360?

CVE-2025-24360 is a medium-severity vulnerability in nuxt, published on 25 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Nuxt is an open-source web development framework for Vue.js. Starting in version 3.8.1 and prior to version 3.15.3, Nuxt allows any websites to send any requests to the development server and read the response due to default CORS settings. Users with the default server.cors option using Vite builder may get the source code stolen by malicious websites. Version 3.15.3 fixes the vulnerability.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2025-24360?

2 open source packages ship an affected version, including @nuxt/vite-builder.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@nuxt/vite-builder` | npm | From 3.8.1 | 3.15.3 |
| `@nuxt/vite-builder` | npm | From 3.8.1 | 3.15.3 |

## How do I fix CVE-2025-24360?

Upgrade @nuxt/vite-builder to 3.15.3 or later.

## Is CVE-2025-24360 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24360 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24360 and fix it if it is affected.

What it is: CVE-2025-24360 is a medium-severity vulnerability in nuxt, published on 25 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24360 exists.

Affected packages and fixed versions:
- @nuxt/vite-builder (npm): affected from 3.8.1; fixed in 3.15.3
- @nuxt/vite-builder (npm): affected from 3.8.1; fixed in 3.15.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24360/ (Markdown: https://insights.sbomify.com/CVE-2025-24360/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24360
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24360
- OSV: https://osv.dev/vulnerability/CVE-2025-24360

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24360/
Summaries are generated and may contain mistakes; the official description above is the record.
