# CVE-2025-24367: Cacti allows Arbitrary File Creation leading to RCE

> An authenticated user can create arbitrary PHP scripts via graph templates, leading to remote code execution on the Cacti server.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jan 2025
- **Updated:** 3 Nov 2025
- **Also known as:** DEBIAN-CVE-2025-24367, GHSA-fxrq-fr7h-9rqq, UBUNTU-CVE-2025-24367

## What is CVE-2025-24367?

CVE-2025-24367 is a high-severity vulnerability in Cacti Cacti, published on 27 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Cacti is an open source performance and fault management framework. An authenticated Cacti user can abuse graph creation and graph template functionality to create arbitrary PHP scripts in the web root of the application, leading to remote code execution on the server. This vulnerability is fixed in 1.2.29.

Weakness: CWE-144 (Improper Neutralization of Line Delimiters)

## Which versions are affected by CVE-2025-24367?

It affects 1 product.


Products: Cacti Cacti.

## How do I fix CVE-2025-24367?

Upgrade to a fixed version.

## Is CVE-2025-24367 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24367 exists.

Public exploit code:

- Proof of Concept for CVE-2025-24367 (github_poc): https://github.com/TheCyberGeek/CVE-2025-24367-Cacti-PoC
- CVE-2025-24367: Cacti AuthN Graph Template RCE in posix sh (github_poc): https://github.com/matesz44/CVE-2025-24367
- Cacti Graph Template authenticated RCE versions prior to 1.2.29 (metasploit)
- CVE-2025-24367 - Cacti Authenticated Graph Template RCE (github_poc): https://github.com/r3vpwnx/CVE-2025-24367
- Authenticated RCE PoC for Cacti (CVE‑2025‑24367). Uses graph template injection to write and execute a payload via the “Unix – Logged in Users” template. Intended for labs and controlled testing only. (github_poc): https://github.com/SoftAndoWetto/CVE-2025-24367-PoC-Cacti
- https://github.com/ShoshinMaster/CVE-2025-24367 (github_poc): https://github.com/ShoshinMaster/CVE-2025-24367

## Other vulnerabilities in Cacti Cacti

- [CVE-2022-46169](https://insights.sbomify.com/CVE-2022-46169/): Cacti Command Injection (critical 9.8, exploited in the wild)
- [CVE-2026-39893](https://insights.sbomify.com/CVE-2026-39893/): Cacti: Pre-authentication SQL injection via rfilter RLIKE clause in graph_view.php (critical 9.8)
- [CVE-2026-39938](https://insights.sbomify.com/CVE-2026-39938/): Cacti: Unauthenticated RCE on Graph Image (critical 9.8)
- [CVE-2026-39955](https://insights.sbomify.com/CVE-2026-39955/): Cacti has Pre-Authentication SQL Injection via unanchored FILTER_VALIDATE_REGEXP in graph_view.php (critical 9.8)
- [CVE-2023-39361](https://insights.sbomify.com/CVE-2023-39361/): Unauthenticated SQL Injection in graph_view.php in Cacti (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24367 and fix it if it is affected.

What it is: CVE-2025-24367 is a high-severity vulnerability in Cacti Cacti, published on 27 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24367 exists.

Affected product: Cacti Cacti. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24367/ (Markdown: https://insights.sbomify.com/CVE-2025-24367/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24367
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24367
- OSV: https://osv.dev/vulnerability/CVE-2025-24367

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24367/
Summaries are generated and may contain mistakes; the official description above is the record.
