# CVE-2025-24370: Django-Unicorn Class Pollution Vulnerability, Leading to XSS, DoS and Authentication Bypass

> Attackers can exploit class pollution in Django-Unicorn to achieve code execution, bypass authentication, or cause denial of service.

- **Severity:** Critical 9.3 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 3 Feb 2025
- **Updated:** 4 Feb 2025
- **Also known as:** GHSA-g9wf-5777-gq43, PYSEC-2026-329

## What is CVE-2025-24370?

CVE-2025-24370 is a critical code injection vulnerability in adamghill django-unicorn, published on 3 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Django-Unicorn adds modern reactive component functionality to Django templates. Affected versions of Django-Unicorn are vulnerable to python class pollution vulnerability. The vulnerability arises from the core functionality `set_property_value`, which can be remotely triggered by users by crafting appropriate component requests and feeding in values of second and third parameter to the vulnerable function, leading to arbitrary changes to the python runtime status. With this finding at least five ways of vulnerability exploitation have been observed, stably resulting in Cross-Site Scripting (XSS), Denial of Service (DoS), and Authentication Bypass attacks in almost every Django-Unicorn-based application. This issue has been addressed in version 0.62.0 and all users are advised to upgrade. There are no known workarounds for this vulnerability.

Weakness: CWE-915 (Improperly Controlled Modification of Dynamically-Determined Object Attributes)

## Which versions are affected by CVE-2025-24370?

3 open source packages ship an affected version, including django-unicorn.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `django-unicorn` | PyPI | All versions | 0.62.0 |
| `django-unicorn` | PyPI | All versions | 0.62.0 |
| `django-unicorn` | PyPI | All versions | 0.62.0 |

## How do I fix CVE-2025-24370?

Upgrade django-unicorn to 0.62.0 or later.

## Is CVE-2025-24370 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24370 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24370 and fix it if it is affected.

What it is: CVE-2025-24370 is a critical code injection vulnerability in adamghill django-unicorn, published on 3 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2025-24370 exists.

Affected packages and fixed versions:
- django-unicorn (PyPI): affected all versions; fixed in 0.62.0
- django-unicorn (PyPI): affected all versions; fixed in 0.62.0
- django-unicorn (PyPI): affected all versions; fixed in 0.62.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24370/ (Markdown: https://insights.sbomify.com/CVE-2025-24370/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24370
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24370
- OSV: https://osv.dev/vulnerability/CVE-2025-24370

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24370/
Summaries are generated and may contain mistakes; the official description above is the record.
