CVE-2025-24372 XSS vector in user uploaded images in group/org and user profiles in ckan
Attackers can upload malicious files to trigger XSS, potentially escalating privileges if an administrator views the file.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2025-24372?
CVE-2025-24372 is a high-severity cross-site scripting vulnerability in ckan, published on 5 Feb 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Official description
CKAN is an open-source DMS (data management system) for powering data hubs and data portals. Using a specially crafted file, a user could potentially upload a file containing code that when executed could send arbitrary requests to the server. If that file was opened by an administrator, it could lead to escalation of privileges of the original submitter or other malicious actions. Users must have been registered to the site to exploit this vulnerability. This vulnerability has been fixed in CKAN 2.10.7 and 2.11.2. Users are advised to upgrade. On versions prior to CKAN 2.10.7 and 2.11.2, site maintainers can restrict the file types supported for uploading using the `ckan.upload.user.mimetypes` / `ckan.upload.user.types` and `ckan.upload.group.mimetypes` / `ckan.upload.group.types` config options. To entirely disable file uploads users can use: `ckan.upload.user.types = none`
Weakness: CWE-79
Which versions are affected by CVE-2025-24372?
5 open source packages ship an affected version, including ckan.
| Package | Affected | Fixed in |
|---|---|---|
ckan PyPI | All versions | 2.10.7, 2.11.2 |
ckan PyPI | All versions | 2.10.7 |
ckan PyPI | All versions | 2.10.7 |
ckan PyPI | From 2.11.0 | 2.11.2 |
ckan PyPI | From 2.11.0 | 2.11.2 |
How do I fix CVE-2025-24372?
Upgrade ckan to a fixed version for your release line: 2.10.7 or 2.11.2.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2025-24372 being exploited?
There is no known exploitation of CVE-2025-24372 in the wild and no public exploit code.
Sources
Also known as GHSA-7pq5-qcp6-mcww, PYSEC-2026-1250.