# CVE-2025-24372: XSS vector in user uploaded images in group/org and user profiles in ckan

> Attackers can upload malicious files to trigger XSS, potentially escalating privileges if an administrator views the file.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 5 Feb 2025
- **Updated:** 5 Feb 2025
- **Also known as:** GHSA-7pq5-qcp6-mcww, PYSEC-2026-1250

## What is CVE-2025-24372?

CVE-2025-24372 is a high-severity cross-site scripting vulnerability in ckan, published on 5 Feb 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

CKAN is an open-source DMS (data management system) for powering data hubs and data portals. Using a specially crafted file, a user could potentially upload a file containing code that when executed could send arbitrary requests to the server. If that file was opened by an administrator, it could lead to escalation of privileges of the original submitter or other malicious actions. Users must have been registered to the site to exploit this vulnerability. This vulnerability has been fixed in CKAN 2.10.7 and 2.11.2. Users are advised to upgrade. On versions prior to CKAN 2.10.7 and 2.11.2, site maintainers can restrict the file types supported for uploading using the `ckan.upload.user.mimetypes` / `ckan.upload.user.types` and `ckan.upload.group.mimetypes` / `ckan.upload.group.types` config options. To entirely disable file uploads users can use: `ckan.upload.user.types = none`

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-24372?

5 open source packages ship an affected version, including ckan.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ckan` | PyPI | All versions | 2.10.7, 2.11.2 |
| `ckan` | PyPI | All versions | 2.10.7 |
| `ckan` | PyPI | All versions | 2.10.7 |
| `ckan` | PyPI | From 2.11.0 | 2.11.2 |
| `ckan` | PyPI | From 2.11.0 | 2.11.2 |

## How do I fix CVE-2025-24372?

Upgrade ckan to a fixed version for your release line: 2.10.7 or 2.11.2.

## Is CVE-2025-24372 being exploited?

There is no known exploitation of CVE-2025-24372 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24372 and fix it if it is affected.

What it is: CVE-2025-24372 is a high-severity cross-site scripting vulnerability in ckan, published on 5 Feb 2025. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-24372 in the wild and no public exploit code.

Affected packages and fixed versions:
- ckan (PyPI): affected all versions; fixed in 2.10.7, 2.11.2
- ckan (PyPI): affected all versions; fixed in 2.10.7
- ckan (PyPI): affected all versions; fixed in 2.10.7
- ckan (PyPI): affected from 2.11.0; fixed in 2.11.2
- ckan (PyPI): affected from 2.11.0; fixed in 2.11.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24372/ (Markdown: https://insights.sbomify.com/CVE-2025-24372/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24372
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24372
- OSV: https://osv.dev/vulnerability/CVE-2025-24372

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24372/
Summaries are generated and may contain mistakes; the official description above is the record.
