# CVE-2025-24374: Twig fixes a security issue where escaping was missing when using null coalesce operator (??)

> Missing output escaping in Twig's null coalesce operator allows attackers to inject malicious scripts, potentially leading to cross-site scripting attacks.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jan 2025
- **Updated:** 29 Jan 2025
- **Also known as:** DEBIAN-CVE-2025-24374, GHSA-3xg3-cgvq-2xwr, UBUNTU-CVE-2025-24374

## What is CVE-2025-24374?

CVE-2025-24374 is a medium-severity cross-site scripting vulnerability in twigphp Twig, published on 29 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Twig is a template language for PHP. When using the ?? operator, output escaping was missing for the expression on the left side of the operator. This vulnerability is fixed in 3.19.0.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component)

## Which versions are affected by CVE-2025-24374?

2 open source packages ship an affected version, including twig/twig.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `twig/twig` | Packagist | From 3.16.0 | 3.19.0 |
| `twig/twig` | Packagist | From 3.16.0 | 3.19.0 |

## How do I fix CVE-2025-24374?

Upgrade twig/twig to 3.19.0 or later.

## Is CVE-2025-24374 being exploited?

There is no known exploitation of CVE-2025-24374 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24374 and fix it if it is affected.

What it is: CVE-2025-24374 is a medium-severity cross-site scripting vulnerability in twigphp Twig, published on 29 Jan 2025. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-24374 in the wild and no public exploit code.

Affected packages and fixed versions:
- twig/twig (Packagist): affected from 3.16.0; fixed in 3.19.0
- twig/twig (Packagist): affected from 3.16.0; fixed in 3.19.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24374/ (Markdown: https://insights.sbomify.com/CVE-2025-24374/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24374
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24374
- OSV: https://osv.dev/vulnerability/CVE-2025-24374

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24374/
Summaries are generated and may contain mistakes; the official description above is the record.
