# CVE-2025-24397: Incorrect permission check in Jenkins GitLab Plugin allows enumerating credentials IDs

> Attackers with global configure permissions can enumerate GitLab API token and secret text credential IDs in Jenkins.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2025
- **Updated:** 23 Jan 2025
- **Also known as:** GHSA-xhgq-h98j-859v

## What is CVE-2025-24397?

CVE-2025-24397 is a medium-severity vulnerability in Jenkins GitLab Plugin, published on 22 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An incorrect permission check in Jenkins GitLab Plugin 1.9.6 and earlier allows attackers with global Item/Configure permission (while lacking Item/Configure permission on any particular job) to enumerate credential IDs of GitLab API token and Secret text credentials stored in Jenkins.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-24397?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:gitlab-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:gitlab-plugin` | Maven | All versions | 1.9.7 |
| `org.jenkins-ci.plugins:gitlab-plugin` | Maven | All versions | 1.9.7 |

Products: Jenkins Gitlab.

## How do I fix CVE-2025-24397?

Upgrade org.jenkins-ci.plugins:gitlab-plugin to 1.9.7 or later.

## Is CVE-2025-24397 being exploited?

There is no known exploitation of CVE-2025-24397 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins GitLab Plugin

- [CVE-2019-10301](https://insights.sbomify.com/CVE-2019-10301/): Jenkins GitLab Plugin missing permission checks (high 8.8)
- [CVE-2019-10300](https://insights.sbomify.com/CVE-2019-10300/): Jenkins GitLab Plugin Cross-Site Request Forgery vulnerability (high 8.0)
- [CVE-2022-30955](https://insights.sbomify.com/CVE-2022-30955/): Missing permission check in Jenkins GitLab Plugin (medium 6.5)
- [CVE-2022-34777](https://insights.sbomify.com/CVE-2022-34777/): Cross-site Scripting in Jenkins GitLab Plugin (medium 5.4)
- [CVE-2022-43411](https://insights.sbomify.com/CVE-2022-43411/): Non-constant time webhook token comparison in Jenkins GitLab Plugin (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24397 and fix it if it is affected.

What it is: CVE-2025-24397 is a medium-severity vulnerability in Jenkins GitLab Plugin, published on 22 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24397 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:gitlab-plugin (Maven): affected all versions; fixed in 1.9.7
- org.jenkins-ci.plugins:gitlab-plugin (Maven): affected all versions; fixed in 1.9.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24397/ (Markdown: https://insights.sbomify.com/CVE-2025-24397/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24397
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24397
- OSV: https://osv.dev/vulnerability/CVE-2025-24397

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24397/
Summaries are generated and may contain mistakes; the official description above is the record.
