# CVE-2025-24399: Improper handling of case sensitivity in Jenkins OpenId Connect Authentication Plugin

> Attackers can bypass authentication and gain administrator access by exploiting case-insensitive username handling in Jenkins OpenID Connect plugin.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2025
- **Updated:** 18 Mar 2025
- **Also known as:** GHSA-q9cm-88jx-3vfw

## What is CVE-2025-24399?

CVE-2025-24399 is a high-severity authentication bypass vulnerability in Jenkins OpenId Connect Authentication Plugin, published on 22 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins OpenId Connect Authentication Plugin 4.452.v2849b_d3945fa_ and earlier, except 4.438.440.v3f5f201de5dc, treats usernames as case-insensitive, allowing attackers on Jenkins instances configured with a case-sensitive OpenID Connect provider to log in as any user by providing a username that differs only in letter case, potentially gaining administrator access to Jenkins.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2025-24399?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:oic-auth. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:oic-auth` | Maven | All versions | 4.453.v4d7765c854f4 |
| `org.jenkins-ci.plugins:oic-auth` | Maven | All versions | 4.453.v4d7765c854f4 |

Products: Jenkins Openid Connect Authentication.

## How do I fix CVE-2025-24399?

Upgrade org.jenkins-ci.plugins:oic-auth to 4.453.v4d7765c854f4 or later.

## Is CVE-2025-24399 being exploited?

There is no known exploitation of CVE-2025-24399 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins OpenId Connect Authentication Plugin

- [CVE-2024-52553](https://insights.sbomify.com/CVE-2024-52553/): Session fixation vulnerability in Jenkins OpenId Connect Authentication Plugin (high 8.8)
- [CVE-2023-24424](https://insights.sbomify.com/CVE-2023-24424/): Session fixation vulnerability in Jenkins OpenId Connect Authentication Plugin (high 8.8)
- [CVE-2024-47806](https://insights.sbomify.com/CVE-2024-47806/): Jenkins OpenId Connect Authentication Plugin lacks audience claim validation (high 8.1)
- [CVE-2024-47807](https://insights.sbomify.com/CVE-2024-47807/): Jenkins OpenId Connect Authentication Plugin lacks issuer claim validation (high 8.1)
- [CVE-2023-50771](https://insights.sbomify.com/CVE-2023-50771/): Open redirect vulnerability in Jenkins OpenId Connect Authentication Plugin (medium 6.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24399 and fix it if it is affected.

What it is: CVE-2025-24399 is a high-severity authentication bypass vulnerability in Jenkins OpenId Connect Authentication Plugin, published on 22 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24399 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:oic-auth (Maven): affected all versions; fixed in 4.453.v4d7765c854f4
- org.jenkins-ci.plugins:oic-auth (Maven): affected all versions; fixed in 4.453.v4d7765c854f4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24399/ (Markdown: https://insights.sbomify.com/CVE-2025-24399/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24399
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24399
- OSV: https://osv.dev/vulnerability/CVE-2025-24399

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24399/
Summaries are generated and may contain mistakes; the official description above is the record.
