{"answers":{"affected":"2 open source packages ship an affected version, including com.axis.jenkins.plugins.eiffel:eiffel-broadcaster. It affects 1 product.","exploited":"There is no known exploitation of CVE-2025-24400 in the wild and no public exploit code.","fix":"Upgrade com.axis.jenkins.plugins.eiffel:eiffel-broadcaster to 2.10.3 or later.","what":"CVE-2025-24400 is a medium-severity missing authorization vulnerability in Jenkins Eiffel Broadcaster Plugin, published on 22 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-24400 and fix it if it is affected.\n\nWhat it is: CVE-2025-24400 is a medium-severity missing authorization vulnerability in Jenkins Eiffel Broadcaster Plugin, published on 22 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-24400 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.axis.jenkins.plugins.eiffel:eiffel-broadcaster (Maven): affected from 2.8.0; fixed in 2.10.3\n- com.axis.jenkins.plugins.eiffel:eiffel-broadcaster (Maven): affected from 2.8.0; fixed in 2.10.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24400/ (Markdown: https://insights.sbomify.com/CVE-2025-24400/index.md)","id":"CVE-2025-24400","markdown":"https://insights.sbomify.com/CVE-2025-24400/index.md","name":"CVE-2025-24400","record":{"aliases":["GHSA-fpw7-8gjc-jwqj"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Eiffel Broadcaster Plugin","requires_auth":"low_privilege","summary":"Attackers can sign events with legitimate credentials by creating a credential with a matching ID in a different store, bypassing authorization checks.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"jenkins","cpe":[{"product":"eiffel_broadcaster","vendor":"jenkins"}],"cvss":{"score":4.3,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-863","name":"Incorrect Authorization"}],"description":"Jenkins Eiffel Broadcaster Plugin 2.8.0 through 2.10.2 (both inclusive) uses the credential ID as the cache key during signing operations, allowing attackers able to create a credential with the same ID as a legitimate one in a different credentials store to sign an event published to RabbitMQ with the legitimate credentials.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Cache confusion in Jenkins Eiffel Broadcaster Plugin","id":"CVE-2025-24400","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"missing_authorization","year":"2025"},"n_packages":2,"n_references":1,"next":{"headline":"Disabled permissions can be granted by Folder-based in Jenkins Authorization Strategy Plugin","id":"CVE-2025-24401"},"packages":[{"ecosystem":"Maven","fixed":["2.10.3"],"introduced":["2.8.0"],"last_affected":[],"package":"com.axis.jenkins.plugins.eiffel:eiffel-broadcaster","purl":null,"source":"GHSA-fpw7-8gjc-jwqj"},{"ecosystem":"Maven","fixed":["2.10.3"],"introduced":["2.8.0"],"last_affected":[],"package":"com.axis.jenkins.plugins.eiffel:eiffel-broadcaster","purl":"pkg:maven/com.axis.jenkins.plugins.eiffel/eiffel-broadcaster","source":"GHSA-fpw7-8gjc-jwqj"}],"prev":{"headline":"Improper handling of case sensitivity in Jenkins OpenId Connect Authentication Plugin","id":"CVE-2025-24399"},"products":["Jenkins Eiffel Broadcaster Plugin"],"published":"2025-01-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-03-20","vendors":["Jenkins Project"]},"summary":"Attackers can sign events with legitimate credentials by creating a credential with a matching ID in a different store, bypassing authorization checks.","url":"https://insights.sbomify.com/CVE-2025-24400/"}