# CVE-2025-24400: Cache confusion in Jenkins Eiffel Broadcaster Plugin

> Attackers can sign events with legitimate credentials by creating a credential with a matching ID in a different store, bypassing authorization checks.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jan 2025
- **Updated:** 20 Mar 2025
- **Also known as:** GHSA-fpw7-8gjc-jwqj

## What is CVE-2025-24400?

CVE-2025-24400 is a medium-severity missing authorization vulnerability in Jenkins Eiffel Broadcaster Plugin, published on 22 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Jenkins Eiffel Broadcaster Plugin 2.8.0 through 2.10.2 (both inclusive) uses the credential ID as the cache key during signing operations, allowing attackers able to create a credential with the same ID as a legitimate one in a different credentials store to sign an event published to RabbitMQ with the legitimate credentials.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-24400?

2 open source packages ship an affected version, including com.axis.jenkins.plugins.eiffel:eiffel-broadcaster. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.axis.jenkins.plugins.eiffel:eiffel-broadcaster` | Maven | From 2.8.0 | 2.10.3 |
| `com.axis.jenkins.plugins.eiffel:eiffel-broadcaster` | Maven | From 2.8.0 | 2.10.3 |

Products: Jenkins Eiffel Broadcaster.

## How do I fix CVE-2025-24400?

Upgrade com.axis.jenkins.plugins.eiffel:eiffel-broadcaster to 2.10.3 or later.

## Is CVE-2025-24400 being exploited?

There is no known exploitation of CVE-2025-24400 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24400 and fix it if it is affected.

What it is: CVE-2025-24400 is a medium-severity missing authorization vulnerability in Jenkins Eiffel Broadcaster Plugin, published on 22 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24400 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.axis.jenkins.plugins.eiffel:eiffel-broadcaster (Maven): affected from 2.8.0; fixed in 2.10.3
- com.axis.jenkins.plugins.eiffel:eiffel-broadcaster (Maven): affected from 2.8.0; fixed in 2.10.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24400/ (Markdown: https://insights.sbomify.com/CVE-2025-24400/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24400
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24400
- OSV: https://osv.dev/vulnerability/CVE-2025-24400

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24400/
Summaries are generated and may contain mistakes; the official description above is the record.
