# CVE-2025-24434: Adobe Commerce | Incorrect Authorization (CWE-863)

> Attackers can bypass authorization checks to escalate privileges and take over sessions in Adobe Commerce without user interaction.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Feb 2025
- **Updated:** 26 Feb 2026
- **Also known as:** GHSA-fppq-f2m6-xv5c

## What is CVE-2025-24434?

CVE-2025-24434 is a critical missing authorization vulnerability in Adobe Commerce, published on 11 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Adobe Commerce versions 2.4.8-beta1, 2.4.7-p3, 2.4.6-p8, 2.4.5-p10, 2.4.4-p11 and earlier are affected by an Incorrect Authorization vulnerability that could result in Privilege escalation. An attacker could leverage this vulnerability to bypass security measures and gain unauthorized access. Exploitation of this issue does not require user interaction. A successful attacker can abuse this to achieve session takeover, increasing the confidentiality and integrity impact as high.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2025-24434?

12 open source packages ship an affected version, including magento/community-edition and magento/project-community-edition. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `magento/community-edition` | Packagist | All versions | 2.4.4-p12 |
| `magento/community-edition` | Packagist | All versions | 2.4.4-p12 |
| `magento/community-edition` | Packagist | From 2.4.5-p1 | 2.4.5-p11 |
| `magento/community-edition` | Packagist | From 2.4.5-p1 | 2.4.5-p11 |
| `magento/community-edition` | Packagist | From 2.4.6-p1 | 2.4.6-p9 |
| `magento/community-edition` | Packagist | From 2.4.6-p1 | 2.4.6-p9 |
| `magento/community-edition` | Packagist | From 2.4.7-beta1 | 2.4.7-p4 |
| `magento/community-edition` | Packagist | From 2.4.7-beta1 | 2.4.7-p4 |
| `magento/community-edition` | Packagist | From 2.4.8-beta1 | 2.4.8-beta2 |
| `magento/community-edition` | Packagist | From 2.4.8-beta1 | 2.4.8-beta2 |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |
| `magento/project-community-edition` | Packagist | All versions to 2.0.2 | None |

Products: Adobe Commerce, Adobe Commerce B2b, Adobe Magento.

## How do I fix CVE-2025-24434?

Upgrade magento/community-edition to a fixed version for your release line: 2.4.4-p12, 2.4.5-p11, 2.4.6-p9 or 2.4.7-p4.

## Is CVE-2025-24434 being exploited?

There is no known exploitation of CVE-2025-24434 in the wild and no public exploit code.

## Other vulnerabilities in Adobe Commerce

- [CVE-2026-75650](https://insights.sbomify.com/CVE-2026-75650/): Adobe Commerce and Magento Improper Neutralization of Special Elements Used in a Template Engine (critical 10.0, exploited in the wild)
- [CVE-2024-34102](https://insights.sbomify.com/CVE-2024-34102/): Adobe Commerce and Magento Open Source Improper Restriction of XML External Entity Reference (XXE) (critical 9.8, exploited in the wild)
- [CVE-2022-24086](https://insights.sbomify.com/CVE-2022-24086/): Adobe Commerce and Magento Open Source Improper Input Validation (critical 9.8, exploited in the wild)
- [CVE-2026-48356](https://insights.sbomify.com/CVE-2026-48356/): Adobe Commerce and Magento Unrestricted Upload of File with Dangerous Type (critical 9.3, exploited in the wild)
- [CVE-2026-71362](https://insights.sbomify.com/CVE-2026-71362/): Adobe Commerce and Magento Incorrect Authorization Vulnerability (critical 9.1, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24434 and fix it if it is affected.

What it is: CVE-2025-24434 is a critical missing authorization vulnerability in Adobe Commerce, published on 11 Feb 2025. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24434 in the wild and no public exploit code.

Affected packages and fixed versions:
- magento/community-edition (Packagist): affected all versions; fixed in 2.4.4-p12
- magento/community-edition (Packagist): affected all versions; fixed in 2.4.4-p12
- magento/community-edition (Packagist): affected from 2.4.5-p1; fixed in 2.4.5-p11
- magento/community-edition (Packagist): affected from 2.4.5-p1; fixed in 2.4.5-p11
- magento/community-edition (Packagist): affected from 2.4.6-p1; fixed in 2.4.6-p9
- magento/community-edition (Packagist): affected from 2.4.6-p1; fixed in 2.4.6-p9
- magento/community-edition (Packagist): affected from 2.4.7-beta1; fixed in 2.4.7-p4
- magento/community-edition (Packagist): affected from 2.4.7-beta1; fixed in 2.4.7-p4
- magento/community-edition (Packagist): affected from 2.4.8-beta1; fixed in 2.4.8-beta2
- magento/community-edition (Packagist): affected from 2.4.8-beta1; fixed in 2.4.8-beta2
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed
- magento/project-community-edition (Packagist): affected all versions up to 2.0.2; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24434/ (Markdown: https://insights.sbomify.com/CVE-2025-24434/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24434
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24434
- OSV: https://osv.dev/vulnerability/CVE-2025-24434

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24434/
Summaries are generated and may contain mistakes; the official description above is the record.
