CVE-2025-24526 Channel export permitted on archived channel when viewing archived channels is disabled
Attackers can export archived channel contents despite disabled viewing permissions, leading to unauthorized data disclosure in Mattermost.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-24526?
CVE-2025-24526 is a medium-severity missing authorization vulnerability in Mattermost Mattermost Server, published on 24 Feb 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.1.x <= 10.1.3, 10.4.x <= 10.4.1, 9.11.x <= 9.11.7, 10.3.x <= 10.3.2, 10.2.x <= 10.2.2 fail to restrict channel export of archived channels when the "Allow users to view archived channels" is disabled which allows a user to export channel contents when they shouldn't have access to it
Weakness: CWE-863
Which versions are affected by CVE-2025-24526?
14 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250110161910-96195f1bd746 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250110161910-96195f1bd746 |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250110161910-96195f1bd746 |
github.com/mattermost/mattermost/server/v8 Go | From 10.2.0-rc1 | 10.2.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.2.0-rc1 | 10.2.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.3.0-rc1 | 10.3.3 |
8 more packages
github.com/mattermost/mattermost/server/v8 Go | From 10.3.0-rc1 | 10.3.3 |
github.com/mattermost/mattermost/server/v8 Go | From 10.4.0-rc1 | 10.4.2 |
github.com/mattermost/mattermost/server/v8 Go | From 10.4.0-rc1 | 10.4.2 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0-rc1 | 9.11.8 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0-rc1 | 9.11.8 |
github.com/mattermost/mattermost-server Go | From 9.11.0-rc1+incompatible | 9.11.8+incompatible, 10.2.3+incompatible, 10.3.3+incompatible, 10.4.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-24526?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250110161910-96195f1bd746, 10.2.3, 10.3.3 or 10.4.2.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2025-24526 being exploited?
There is no known exploitation of CVE-2025-24526 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-q8p2-2hwc-jw64, GO-2025-3481.