{"answers":{"affected":"3 open source packages ship an affected version, including phpmyadmin/phpmyadmin and phpmyadmin.","exploited":"There is no known exploitation of CVE-2025-24530 in the wild and no public exploit code.","fix":"Upgrade phpmyadmin/phpmyadmin to 5.2.2 or later.","what":"CVE-2025-24530 is a medium-severity cross-site scripting vulnerability in phpMyAdmin, published on 23 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-24530 and fix it if it is affected.\n\nWhat it is: CVE-2025-24530 is a medium-severity cross-site scripting vulnerability in phpMyAdmin, published on 23 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-24530 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.2.2\n- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.2.2\n- phpmyadmin (Bitnami): affected from 5.0.0; fixed in 5.2.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24530/ (Markdown: https://insights.sbomify.com/CVE-2025-24530/index.md)","id":"CVE-2025-24530","markdown":"https://insights.sbomify.com/CVE-2025-24530/index.md","name":"CVE-2025-24530","record":{"aliases":["BIT-phpmyadmin-2025-24530","DEBIAN-CVE-2025-24530","GHSA-222v-cx2c-q2f5","UBUNTU-CVE-2025-24530"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"phpMyAdmin","requires_auth":"low_privilege","summary":"Cross-site scripting in phpMyAdmin allows attackers to execute scripts via crafted table or database names, potentially compromising user sessions.","user_interaction":"not_required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":6.4,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"An issue was discovered in phpMyAdmin 5.x before 5.2.2. An XSS vulnerability has been discovered for the check tables feature. A crafted table or database name could be used for XSS.","ecosystems":["Bitnami","Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"phpMyAdmin XSS when checking tables","id":"CVE-2025-24530","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2025"},"n_packages":3,"n_references":1,"next":{"headline":"Auth bypass in pam pkcs11","id":"CVE-2025-24531"},"packages":[{"ecosystem":"Bitnami","fixed":["5.2.2"],"introduced":["5.0.0"],"last_affected":[],"package":"phpmyadmin","purl":"pkg:bitnami/phpmyadmin","source":"BIT-phpmyadmin-2025-24530"},{"ecosystem":"Packagist","fixed":["5.2.2"],"introduced":["5.0.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":null,"source":"GHSA-222v-cx2c-q2f5"},{"ecosystem":"Packagist","fixed":["5.2.2"],"introduced":["5.0.0"],"last_affected":[],"package":"phpmyadmin/phpmyadmin","purl":"pkg:composer/phpmyadmin/phpmyadmin","source":"GHSA-222v-cx2c-q2f5"}],"prev":{"headline":"Cross-site scripting in phpMyAdmin","id":"CVE-2025-24529"},"products":["phpMyAdmin"],"published":"2025-01-23","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2025-11-03","vendors":["phpMyAdmin"]},"summary":"Cross-site scripting in phpMyAdmin allows attackers to execute scripts via crafted table or database names, potentially compromising user sessions.","url":"https://insights.sbomify.com/CVE-2025-24530/"}