# CVE-2025-24530: phpMyAdmin XSS when checking tables

> Cross-site scripting in phpMyAdmin allows attackers to execute scripts via crafted table or database names, potentially compromising user sessions.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jan 2025
- **Updated:** 3 Nov 2025
- **Also known as:** BIT-phpmyadmin-2025-24530, DEBIAN-CVE-2025-24530, GHSA-222v-cx2c-q2f5, UBUNTU-CVE-2025-24530

## What is CVE-2025-24530?

CVE-2025-24530 is a medium-severity cross-site scripting vulnerability in phpMyAdmin, published on 23 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An issue was discovered in phpMyAdmin 5.x before 5.2.2. An XSS vulnerability has been discovered for the check tables feature. A crafted table or database name could be used for XSS.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2025-24530?

3 open source packages ship an affected version, including phpmyadmin/phpmyadmin and phpmyadmin.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `phpmyadmin/phpmyadmin` | Packagist | From 5.0.0 | 5.2.2 |
| `phpmyadmin/phpmyadmin` | Packagist | From 5.0.0 | 5.2.2 |
| `phpmyadmin` | Bitnami | From 5.0.0 | 5.2.2 |

## How do I fix CVE-2025-24530?

Upgrade phpmyadmin/phpmyadmin to 5.2.2 or later.

## Is CVE-2025-24530 being exploited?

There is no known exploitation of CVE-2025-24530 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24530 and fix it if it is affected.

What it is: CVE-2025-24530 is a medium-severity cross-site scripting vulnerability in phpMyAdmin, published on 23 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24530 in the wild and no public exploit code.

Affected packages and fixed versions:
- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.2.2
- phpmyadmin/phpmyadmin (Packagist): affected from 5.0.0; fixed in 5.2.2
- phpmyadmin (Bitnami): affected from 5.0.0; fixed in 5.2.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24530/ (Markdown: https://insights.sbomify.com/CVE-2025-24530/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24530
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24530
- OSV: https://osv.dev/vulnerability/CVE-2025-24530

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24530/
Summaries are generated and may contain mistakes; the official description above is the record.
