{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2025-24531 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2025-24531 is a medium-severity authentication bypass vulnerability in OpenSC project pam_pkcs11, published on 16 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2025-24531 and fix it if it is affected.\n\nWhat it is: CVE-2025-24531 is a medium-severity authentication bypass vulnerability in OpenSC project pam_pkcs11, published on 16 Jan 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2025-24531 in the wild and no public exploit code.\n\nAffected product: OpenSC project pam_pkcs11. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2025-24531/ (Markdown: https://insights.sbomify.com/CVE-2025-24531/index.md)","id":"CVE-2025-24531","markdown":"https://insights.sbomify.com/CVE-2025-24531/index.md","name":"CVE-2025-24531","record":{"aliases":["DEBIAN-CVE-2025-24531","GHSA-7mf6-rg36-qgch","SUSE-SU-2025:20130-1","SUSE-SU-2025:20225-1","UBUNTU-CVE-2025-24531"],"analysis":{"component_type":"operating_system","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"Linux PAM module","requires_auth":"none","summary":"Attackers can bypass authentication by triggering smartcard errors, as the PAM module incorrectly returns ignore status.","user_interaction":"not_required","vuln_class":"auth_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":6.7,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-393","name":"Return of Wrong Status Code"}],"description":"In OpenSC pam_pkcs11 before 0.6.13, pam_sm_authenticate() wrongly returns PAM_IGNORE in many error situations (such as an error triggered by a smartcard before login), allowing authentication bypass.","ecosystems":["SUSE:Linux Micro 6.0","SUSE:Linux Micro 6.1"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Auth bypass in pam pkcs11","id":"CVE-2025-24531","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"auth_bypass","year":"2025"},"n_packages":2,"n_references":3,"next":{"headline":"Missing authorization in SCALANCE WAB762-1","id":"CVE-2025-24532"},"packages":[{"ecosystem":"SUSE:Linux Micro 6.0","fixed":["0.6.12-2.1"],"introduced":["0"],"last_affected":[],"package":"pam_pkcs11","purl":"pkg:rpm/suse/pam_pkcs11\u0026distro=SUSE%20Linux%20Micro%206.0","source":"SUSE-SU-2025:20130-1"},{"ecosystem":"SUSE:Linux Micro 6.1","fixed":["0.6.12-slfo.1.1_3.1"],"introduced":["0"],"last_affected":[],"package":"pam_pkcs11","purl":"pkg:rpm/suse/pam_pkcs11\u0026distro=SUSE%20Linux%20Micro%206.1","source":"SUSE-SU-2025:20225-1"}],"prev":{"headline":"phpMyAdmin XSS when checking tables","id":"CVE-2025-24530"},"products":["pam_pkcs11"],"published":"2026-01-16","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-01-16","vendors":["OpenSC project"]},"summary":"Attackers can bypass authentication by triggering smartcard errors, as the PAM module incorrectly returns ignore status.","url":"https://insights.sbomify.com/CVE-2025-24531/"}