CVE-2025-2475 Unauthorized Bot Login Using Credentials
Attackers can log in to bot accounts once using original user credentials due to stale cache after account conversion.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2025-2475?
CVE-2025-2475 is a medium-severity authentication bypass vulnerability in Mattermost Mattermost Server, published on 14 Apr 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Mattermost versions 10.5.x <= 10.5.1, 10.4.x <= 10.4.3, 9.11.x <= 9.11.9 fail to invalidate the cache when a user account is converted to a bot which allows an attacker to login to the bot exactly one time via normal credentials.
Weakness: CWE-303
Which versions are affected by CVE-2025-2475?
10 open source packages ship an affected version, including github.com/mattermost/mattermost/server/v8, github.com/mattermost/mattermost-server and github.com/mattermost/mattermost-server/v5. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250220161544-fd356b62b4dd |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250220161544-fd356b62b4dd |
github.com/mattermost/mattermost/server/v8 Go | All versions | 8.0.0-20250220161544-fd356b62b4dd |
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.2 |
github.com/mattermost/mattermost/server/v8 Go | From 10.5.0 | 10.5.2 |
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.10 |
4 more packages
github.com/mattermost/mattermost/server/v8 Go | From 9.11.0 | 9.11.10 |
github.com/mattermost/mattermost-server Go | From 9.11.0+incompatible | 9.11.10+incompatible, 10.5.2+incompatible |
github.com/mattermost/mattermost-server/v5 Go | All versions | None |
github.com/mattermost/mattermost-server/v6 Go | All versions | None |
Products include Mattermost Mattermost Server.
How do I fix CVE-2025-2475?
Upgrade github.com/mattermost/mattermost/server/v8 to a fixed version for your release line: 8.0.0-20250220161544-fd356b62b4dd, 10.5.2 or 9.11.10.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2025-2475 being exploited?
There is no known exploitation of CVE-2025-2475 in the wild and no public exploit code.
Other vulnerabilities in Mattermost Mattermost Server
- CVE-2025-12419 Account takeover on OAuth/OpenID-enabled servers
- CVE-2025-12421 Account Takeover via Code Exchange Endpoint
- CVE-2025-4981 Path Traversal Leading to RCE by Any Authenticated Mattermost User
- CVE-2025-20051 Arbitrary file read via block duplication in Mattermost Boards
- CVE-2025-25279 Arbitrary file read in Mattermost Boards via import & export board archive
Sources
Also known as GHSA-6rqh-8465-2xcw, GO-2025-3610.