# CVE-2025-24784: kubewarden-controller has an Information leak via AdmissionPolicyGroup Resource

> Attackers can leak cluster information by creating AdmissionPolicyGroups that leverage context-aware policies with elevated ServiceAccount privileges.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 30 Jan 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-756x-m4mj-q96c, GO-2025-3435

## What is CVE-2025-24784?

CVE-2025-24784 is a medium-severity vulnerability in kubewarden-controller, published on 30 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

kubewarden-controller is a Kubernetes controller that allows you to dynamically register Kubewarden admission policies. The policy group feature, added to by the 1.17.0 release. By being namespaced, the AdmissionPolicyGroup has a well constrained impact on cluster resources. Hence, it’s considered safe to allow non-admin users to create and manage these resources in the namespaces they own. Kubewarden policies can be allowed to query the Kubernetes API at evaluation time; these types of policies are called “context aware“. Context aware policies can perform list and get operations against a Kubernetes cluster. The queries are done using the ServiceAccount of the Policy Server instance that hosts the policy. That means that access to the cluster is determined by the RBAC rules that apply to that ServiceAccount. The AdmissionPolicyGroup CRD allowed the deployment of context aware policies. This could allow an attacker to obtain information about resources that are out of their reach, by leveraging a higher access to the cluster granted to the ServiceAccount token used to run the policy. The impact of this vulnerability depends on the privileges that have been granted to the ServiceAccount used to run the Policy Server and assumes that users are using the recommended best practices of keeping the Policy Server's ServiceAccount least privileged. By default, the Kubewarden helm chart grants access to the following resources (cluster wide) only: Namespace, Pod, Deployment and Ingress. This vulnerability is fixed in 1.21.0.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2025-24784?

3 open source packages ship an affected version, including github.com/kubewarden/kubewarden-controller.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/kubewarden/kubewarden-controller` | Go | From 1.17.0 | 1.21.0 |
| `github.com/kubewarden/kubewarden-controller` | Go | From 1.17.0 | 1.21.0 |
| `github.com/kubewarden/kubewarden-controller` | Go | From 1.17.0 | 1.21.0 |

## How do I fix CVE-2025-24784?

Upgrade github.com/kubewarden/kubewarden-controller to 1.21.0 or later.

## Is CVE-2025-24784 being exploited?

There is no known exploitation of CVE-2025-24784 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24784 and fix it if it is affected.

What it is: CVE-2025-24784 is a medium-severity vulnerability in kubewarden-controller, published on 30 Jan 2025. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24784 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/kubewarden/kubewarden-controller (Go): affected from 1.17.0; fixed in 1.21.0
- github.com/kubewarden/kubewarden-controller (Go): affected from 1.17.0; fixed in 1.21.0
- github.com/kubewarden/kubewarden-controller (Go): affected from 1.17.0; fixed in 1.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24784/ (Markdown: https://insights.sbomify.com/CVE-2025-24784/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24784
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24784
- OSV: https://osv.dev/vulnerability/CVE-2025-24784

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24784/
Summaries are generated and may contain mistakes; the official description above is the record.
