# CVE-2025-24788: Snowflake Connector for .NET has weak temporary files permissions

> Local attackers can read sensitive data from temporary files due to weak permissions in the Snowflake .NET connector.

- **Severity:** Medium 5.0 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:R/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 29 Jan 2025
- **Updated:** 31 Jan 2025
- **Also known as:** GHSA-2mqw-rq5m-8hc8

## What is CVE-2025-24788?

CVE-2025-24788 is a medium-severity vulnerability in snowflakedb snowflake-connector-net, published on 29 Jan 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

snowflake-connector-net is the Snowflake Connector for .NET. Snowflake discovered and remediated a vulnerability in the Snowflake Connector for .NET in which files downloaded from stages are temporarily placed in a world-readable local directory, making them accessible to unauthorized users on the same machine. This vulnerability affects versions 2.0.12 through 4.2.0 on Linux and macOS. Snowflake fixed the issue in version 4.3.0.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2025-24788?

2 open source packages ship an affected version, including Snowflake.Data. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `Snowflake.Data` | NuGet | From 2.0.12 | 4.3.0 |
| `Snowflake.Data` | NuGet | From 2.0.12 | 4.3.0 |

Products: Snowflake Snowflake Connector.

## How do I fix CVE-2025-24788?

Upgrade Snowflake.Data to 4.3.0 or later.

## Is CVE-2025-24788 being exploited?

There is no known exploitation of CVE-2025-24788 in the wild and no public exploit code.

## Other vulnerabilities in snowflakedb snowflake-connector-net

- [CVE-2023-34230](https://insights.sbomify.com/CVE-2023-34230/): Snowflake Connector vulnerable to Command Injection (high 7.3)
- [CVE-2023-34232](https://insights.sbomify.com/CVE-2023-34232/): Snowflake NodeJS Driver vulnerable to Command Injection (high 7.3)
- [CVE-2023-34233](https://insights.sbomify.com/CVE-2023-34233/): Snowflake Python Connector vulnerable to Command Injection (high 7.3)
- [CVE-2025-24793](https://insights.sbomify.com/CVE-2025-24793/): Snowflake Connector for Python has an SQL Injection in write_pandas (high 7.0)
- [CVE-2025-24794](https://insights.sbomify.com/CVE-2025-24794/): The Snowflake Connector for Python uses insecure deserialization of the OCSP response cache (medium 6.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24788 and fix it if it is affected.

What it is: CVE-2025-24788 is a medium-severity vulnerability in snowflakedb snowflake-connector-net, published on 29 Jan 2025. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2025-24788 in the wild and no public exploit code.

Affected packages and fixed versions:
- Snowflake.Data (NuGet): affected from 2.0.12; fixed in 4.3.0
- Snowflake.Data (NuGet): affected from 2.0.12; fixed in 4.3.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24788/ (Markdown: https://insights.sbomify.com/CVE-2025-24788/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24788
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24788
- OSV: https://osv.dev/vulnerability/CVE-2025-24788

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24788/
Summaries are generated and may contain mistakes; the official description above is the record.
