CVE-2025-24790 Snowflake JDBC uses insecure temporary credential cache file permissions

Medium 4.4 Published Updated

Local attackers can read cached Snowflake credentials from world-readable files on Linux when temporary caching is enabled.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2025-24790?

CVE-2025-24790 is a medium-severity vulnerability in snowflakedb snowflake-jdbc, published on 29 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Snowflake JDBC provides a JDBC type 4 driver that supports core functionality, allowing Java program to connect to Snowflake. Snowflake discovered and remediated a vulnerability in the Snowflake JDBC Driver. On Linux systems, when temporary credential caching is enabled, the Snowflake JDBC Driver will cache temporary credentials locally in a world-readable file. This vulnerability affects versions 3.6.8 through 3.21.0. Snowflake fixed the issue in version 3.22.0.

Weakness: CWE-276

Which versions are affected by CVE-2025-24790?

2 open source packages ship an affected version, including net.snowflake:snowflake-jdbc. It affects 1 product.

PackageAffectedFixed in
net.snowflake:snowflake-jdbc MavenFrom 3.6.83.22.0
net.snowflake:snowflake-jdbc MavenFrom 3.6.83.22.0

Products include Snowflake Snowflake Jdbc.

How do I fix CVE-2025-24790?

Upgrade net.snowflake:snowflake-jdbc to 3.22.0 or later.

Is CVE-2025-24790 being exploited?

There is no known exploitation of CVE-2025-24790 in the wild and no public exploit code.

Sources

Also known as GHSA-33g6-495w-v8j2.

Is CVE-2025-24790 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free