# CVE-2025-24790: Snowflake JDBC uses insecure temporary credential cache file permissions

> Local attackers can read cached Snowflake credentials from world-readable files on Linux when temporary caching is enabled.

- **Severity:** Medium 4.4 (`CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Local or same network only
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jan 2025
- **Updated:** 12 Feb 2025
- **Also known as:** GHSA-33g6-495w-v8j2

## What is CVE-2025-24790?

CVE-2025-24790 is a medium-severity vulnerability in snowflakedb snowflake-jdbc, published on 29 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.

### Official description

Snowflake JDBC provides a JDBC type 4 driver that supports core functionality, allowing Java program to connect to Snowflake. Snowflake discovered and remediated a vulnerability in the Snowflake JDBC Driver. On Linux systems, when temporary credential caching is enabled, the Snowflake JDBC Driver will cache temporary credentials locally in a world-readable file. This vulnerability affects versions 3.6.8 through 3.21.0. Snowflake fixed the issue in version 3.22.0.

Weakness: CWE-276 (Incorrect Default Permissions)

## Which versions are affected by CVE-2025-24790?

2 open source packages ship an affected version, including net.snowflake:snowflake-jdbc. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `net.snowflake:snowflake-jdbc` | Maven | From 3.6.8 | 3.22.0 |
| `net.snowflake:snowflake-jdbc` | Maven | From 3.6.8 | 3.22.0 |

Products: Snowflake Snowflake Jdbc.

## How do I fix CVE-2025-24790?

Upgrade net.snowflake:snowflake-jdbc to 3.22.0 or later.

## Is CVE-2025-24790 being exploited?

There is no known exploitation of CVE-2025-24790 in the wild and no public exploit code.

## Other vulnerabilities in snowflakedb snowflake-jdbc

- [CVE-2025-24789](https://insights.sbomify.com/CVE-2025-24789/): Snowflake JDBC allows an untrusted search path on Windows (high 7.8)
- [CVE-2023-30535](https://insights.sbomify.com/CVE-2023-30535/): Snowflake JDBC vulnerable to command injection via SSO URL authentication (high 7.3)
- [CVE-2024-43382](https://insights.sbomify.com/CVE-2024-43382/): Snowflake JDBC Security Advisory (medium 5.9)
- [CVE-2026-3293](https://insights.sbomify.com/CVE-2026-3293/): snowflakedb snowflake-jdbc JDBC URL SdkProxyRoutePlanner.java SdkProxyRoutePlanner redos (medium 4.8)
- [CVE-2025-27496](https://insights.sbomify.com/CVE-2025-27496/): Snowflake JDBC Driver client-side encryption key in DEBUG logs (low 3.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2025-24790 and fix it if it is affected.

What it is: CVE-2025-24790 is a medium-severity vulnerability in snowflakedb snowflake-jdbc, published on 29 Jan 2025. It can only be exploited from the same machine or local network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2025-24790 in the wild and no public exploit code.

Affected packages and fixed versions:
- net.snowflake:snowflake-jdbc (Maven): affected from 3.6.8; fixed in 3.22.0
- net.snowflake:snowflake-jdbc (Maven): affected from 3.6.8; fixed in 3.22.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2025-24790/ (Markdown: https://insights.sbomify.com/CVE-2025-24790/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2025-24790
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2025-24790
- OSV: https://osv.dev/vulnerability/CVE-2025-24790

---
From sbomify Insights: https://insights.sbomify.com/CVE-2025-24790/
Summaries are generated and may contain mistakes; the official description above is the record.
